Slidewall doesn't start

Bug #1208931 reported by Alessandro Calabrese
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Slidewall
Undecided
Unassigned

Bug Description

Ubuntu 13.04
Unity

I've installed Slidewall as reported in website updating ppa and installing via apt-get

but program doesn't start.

When started in terminal typing

slidewall --verbose

appears as follows:

slidewall --verbose
Traceback (most recent call last):
  File "/usr/bin/slidewall", line 46, in <module>
    import slidewall
  File "/usr/lib/python2.7/dist-packages/slidewall/__init__.py", line 25, in <module>
    from slidewall import SlidewallWindow
  File "/usr/lib/python2.7/dist-packages/slidewall/SlidewallWindow.py", line 25, in <module>
    from slidewall_lib import Window
  File "/usr/lib/python2.7/dist-packages/slidewall_lib/__init__.py", line 21, in <module>
    from .Window import Window
  File "/usr/lib/python2.7/dist-packages/slidewall_lib/Window.py", line 22, in <module>
    from slidewall_engine import wallbase
  File "/usr/lib/python2.7/dist-packages/slidewall_engine/wallbase.py", line 3, in <module>
    from bs4 import BeautifulSoup
ImportError: No module named bs4

Thanks

tags: added: python-bs4 slidewall
Revision history for this message
Eivar Montenegro (e.mont01) wrote :

I had the same problem in my Ubuntu 13.04 Linux 3.8.0-27-generic x86_64

Long story short:
I solved this problem installing python-bs4 as follows:
sudo apt-get install python-bs4 python-bs4-doc

Long story:
I tried instructions in this two sites:
http://www.noobslab.com/2013/06/slidewall-live-wallpaper-utility-for.html
http://www.webupd8.org/2012/08/use-wallpaper-clocks-live-earth.html

Whe running in a console "slidewall --verbose" the following stacktrace is shown: http://paste.ubuntu.com/5974869/

According to some documentation in [1] and [2] python-bs4 can be installed using this command:
sudo apt-get install python-bs4

I ended up also installing the doc package, just in case I need that documentation later:
sudo apt-get install python-bs4 python-bs4-doc

Is you want to see the full console output see here: http://paste.ubuntu.com/5974850/

[1] http://www.crummy.com/software/BeautifulSoup/bs4/doc/
[2] http://www.pythonforbeginners.com/python-on-the-web/beautifulsoup-4-python/

Revision history for this message
fioan89@gmail.com (fioan89) wrote :

Yes, I was aware of this problem. The thing is, I can't figure why Ubuntu is not installing this dependency when Slidewall is installed. I don't have any problem with other dependencies, only with this one.

Changed in slidewall:
status: New → Confirmed
Revision history for this message
Coeur Noir (coeur-noir) wrote :

I have downloaded the .deb from launchpad to try to install slidewall under ubuntu 13.10 and...

...it worked, using gDebi, which warned about pyhton-bs4, downloaded it end then installed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers