Skype-wrapper do not work

Bug #1052141 reported by Albul Alexander on 2012-09-17
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
skype-wrapper
High
Unassigned

Bug Description

After installation nothing works.
I mean, i tried to re-login, reboot skype and even my PC :)
Ayway, i have no authorization request and as a result, skype is not integrated.
I can try to provide you logs e.t.c. just provide some information on where to get them.

Albul Alexander (aalbul) on 2012-09-17
Changed in skype-wrapper:
status: New → Incomplete
status: Incomplete → New
Toni Förster (stonerl) wrote :

Which Skype version do you use? And from what source, USC or Skype-Website?

valeurz (per-valerio) wrote :

HI,

I am not sure this is the good place.

This is the error I get:
skype-wrapper
Starting skype-wrapper
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
INFO: Initializing Skype API
INFO: Starting Skype process
INFO: Waiting for Skype Process
/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: classe ELF errata: ELFCLASS64

(skype:21850): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: classe ELF errata: ELFCLASS64

(skype:21850): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: classe ELF errata: ELFCLASS64

(skype:21850): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: classe ELF errata: ELFCLASS64

(skype:21850): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

INFO: Attaching skype-wrapper to Skype process
The program 'indicator-applet-skype.py' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 17 error_code 3 request_code 25 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Applet closed

Christian Rupp (grissi) on 2012-09-18
Changed in skype-wrapper:
status: New → Confirmed
importance: Undecided → Medium
importance: Medium → High
valeurz (per-valerio) wrote :

Sorry I forgot the Skype and ubuntu info.

Skype 4.0.0.8. I guess is from USC, but I am not really sure, I can't rember. Is there a way to track it?

I am running Skype on Ubuntu 12.04 64 bit

Christian Rupp (grissi) wrote :

If skype is listened as installed in the USC it should be installed through it because the Software Center is not able to track software from other sources

valeurz (per-valerio) wrote :

Thanks. So i have installed it through the USC

Eduardo Ramiro (eduardo-ramiro) wrote :

When I execute the Skype launcher the wrapper doesn't get executed at all the same for executing "skype" in a CLI. When I execute "skype-wrapper" in a CLI the wrapper works correctly, the only issue I can see is that this info messages appears repeatedly ( every 1 or 2 seconds ) :

INFO: Checking online presence
INFO: Check if Skype instance is running

and it keeps repeating until I exit skype.

Skype version: 4.0.0.8 from Web site
Ubuntu version: 12.10 Beta 1
Wrapper version: Installed from ppa

@valeurz

Just a note .. USC tracks all apt software, its aim is to be a full replacement for synaptic. So even if you install the .deb file from skype itself USC will list it as being able to uninstall .. if there is absolutely no PPA added to describe the application then all that USC will be able to show is the title, package name, version, comments and screenshot.

can you run in terminal the command

"skype-wrapper --sync"

and then post output? Its the only hint at displaying a proper log. Seems to be an issue with how the programme is registered with the X system through gtk, just not sure

@eduardo

I'm assuming that the skype on the launcher is launching "skype" and not "skype-wrapper" .. can you perhaps show us what the content of /usr/share/applications/skype.desktop is and possibly /usr/share/applications/skype-wrapper.desktop? if it exists

did you install / upgrade skype after installing skype-wrapper?

Christian Rupp (grissi) wrote :

@ shannon and eduardo

but if skype-wrapper-launcher is startet automatically, it's better to use skype.desktop in the launcher.

Christian Rupp (grissi) wrote :

Could you please post the terminal output of:

python /usr/share/skype-wrapper/launcher.py

This could be helpful

valeurz (per-valerio) wrote :

Hi.
I have tried to run "skype-wrapper --sync" but it give me no output..

I have tried also "python /usr/share/skype-wrapper/launcher.py". It gives a series of next and nothing happen, I have to kill the command.

the way it works is very odd.
after the installation it does work.
after a month it sometimes works, sometimes doesn't.
I'm on 12.04.2 amd64 kernel 3.5, well, I deciede to purge the package and install the one for quantal then.
after doing that, I started skype and since then the wrapper has worked fine.
I rebooted 2 times bit it still works (for example, in the past it used not to see old messages that I had got, now it does and shows the notification on startup).
It seems for me like something breks it... SInce I'm Russian and chat mostly with the Russians, that might be some Cyrillic symbols (in names of users/conferences or in messages/statuses) or smth like that.
I haven't tried using the conference chat or calling on the 'quantal' version of the wrapper yet, but as as message notifier is works well.
We'll see what happens.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers