wikipedia lens tutorial does not work

Bug #1000669 reported by Schwarzburg
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
singlet
Confirmed
Undecided
Michael Hall

Bug Description

Based on this askubuntu question:
http://askubuntu.com/questions/135399/quickly-lens-tutorial-not-working/138257#138257

I have been following the exact steps of this wikipedia lens tutorial with the result that the quickly run step gives the following warnings and the search does not display any results:

WARN 2012-05-11 10:55:06 unity.glib.dbusproxy GLibDBusProxy.cpp:283 Calling method "InfoRequest" on object path: "/unity/singlet/lens/wikipedia" failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface `com.canonical.Unity.Lens' on object at path /unity/singlet/lens/wikipedia
WARN 2012-05-11 10:55:06 unity.glib.dbusproxy GLibDBusProxy.cpp:283 Calling method "SetViewType" on object path: "/unity/singlet/lens/wikipedia" failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface `com.canonical.Unity.Lens' on object at path /unity/singlet/lens/wikipedia
WARN 2012-05-11 10:55:49 unity.glib.dbusproxy GLibDBusProxy.cpp:283 Calling method "Search" on object path: "/unity/singlet/lens/wikipedia" failed: Timeout was reached

Since I really exactly followed the steps, either something in the tutorial is missing or my setup is different:

>unity --version
unity 5.12.0

>quickly --version
Quickly 12.04
  Python interpreter: /usr/bin/python 2.7.3
  Python standard library: /usr/lib/python2.7

  Quickly used library: /usr/lib/python2.7/dist-packages/quickly
  Quickly data path: /usr/share/quickly
  Quickly detected template directories:
          /usr/share/quickly/templates/

Copyright 2009 Rick Spencer
Copyright 2009-2011 Didier Roche
Copyright 2010-2011 Canonical Ltd
https://launchpad.net/quickly

quickly comes with ABSOLUTELY NO WARRANTY. quickly is free software, and
you may use, modify and redistribute it under the terms of the GNU
General Public License version 3 or later.

>lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

The lens file is there:

$ more /usr/share/unity/lenses/wikipedia/wikipedia.lens
[Lens]
DBusName=unity.singlet.lens.wikipedia
DBusPath=/unity/singlet/lens/wikipedia
Name=Wikipedia
Icon=/usr/share/unity/lenses/wikipedia/unity-lens-wikipedia.svg
Description=Wikipedia Lens
SearchHint=Search Wikipedia
#Shortcut=c

[Desktop Entry]
X-Ubuntu-Gettext-Domain=wikipedia

Revision history for this message
Schwarzburg (stefan-schwarzburg) wrote :
Revision history for this message
jhfhlkjlj (fdsuufijjejejejej-deactivatedaccount) wrote :

Having issues myself. Even though I'm running via 'quickly run' I'm getting:

WARN 2012-04-17 00:25:50 unity.glib.dbusproxy GLibDBusProxy.cpp:283 Calling method “Search” on object path: “/unity/singlet/lens/wikipedia” failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name unity.singlet.lens.wikipedia was not provided by any .service files

I tried to manually copy over the .service file to /usr/lib/dbus-1/services/ but it did not work. I had it working at one point with the same exact code - however, it's all just failing to work now. I've reset my entire unity/compiz configuration. Alas, it does not work.

Changed in singlet:
status: New → Confirmed
Michael Hall (mhall119)
Changed in singlet:
assignee: nobody → Michael Hall (mhall119)
Revision history for this message
Juan Moyano (wincus) wrote :

Same issues here. Any update on this?

Revision history for this message
Gary Bishop (gb-cs) wrote :

You can see this issue in the quickly prototype.

quickly create unity-lens foo
cd foo
sudo quickly install
quickly run

you'll get the same problem.

Revision history for this message
Gary Bishop (gb-cs) wrote :

I believe I see the problem(s).

First, search_on_blank = True does not appear to work. search gets called once and that's it.

Second, on Ubuntu, the lens gets installed in /usr/local/bin but the quickly generated .lens file expects it to be in /usr/bin/

I got my lens working with those two changes.

Revision history for this message
Gary Bishop (gb-cs) wrote :

Ooops. Not the .lens file, rather the .service file.

Revision history for this message
jhfhlkjlj (fdsuufijjejejejej-deactivatedaccount) wrote :

Sorry about the noise - Is there an upstream version that fixes the issue that we can test?

no longer affects: quickly (Ubuntu)
Revision history for this message
Tankypon (tankypon) wrote :

So that's all.. Some people are affected by this bug but anyone have a solution :(
We want to learn how to create a lens but finally we can't, I want too to try to create a lens which is in my mind but I can't now.

Solution?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers