LocationError with ManageChannelsForm

Reported by Roland Schigas on 2011-01-04
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Singing & Dancing
Undecided
Unassigned

Bug Description

Installation via buildout works fine, activating product via Plone Add-On control panel works fine, and I can view the Singing & Dancing config screen. I get the LocationError when clicking on "Mailing-list administration" (portal_newsletters/channels) and also with "Collector administration" (portal_newsletters/collectors). I do not get this error when clicking on "Global settings" or "Statistics".

Dancing 0.9.5, Plone 4.0.2, Zope 2.12.13, Python 2.6.5, Ubuntu Linux 10.04.1

Other add-ons:
Products.ContentWellPortlets==2.1
Products.PloneFormGen==1.6.0
Products.Poi==2.0.1
Products.Scrawl==1.3.2
collective.plonetruegallery==1.0.1
collective.quickupload==1.0.3
quintagroup.dropdownmenu==1.1.1

Daniel Nouri (daniel.nouri) wrote :

Does your Zope start up fine in foreground?

http://plone.org/documentation/kb/ask-for-help/#traceback

Hi, just uninstalled plone marshall, config registry, z3c.form and now it works.. Must be a conflict.

Régis Rouet (regis-rouet) wrote :

Hi,

Hi am also experiencing this bug.

I use collective.plonetruegallery and collective.quickupload too.
And other products like xdv.

Régis Rouet (regis-rouet) wrote :

uninstalling z3c.form support in the quickinstaller make the error disappear here too

It looks like S&D has been developed to work with plone.z3cform.templates/macros.pt
but not plone.app.z3cform.templates/macros.pt

It's a problem since plone.app.z3cform installation instructions tell to install plone.app.z3cform:default GenericSetup extension profile.
Installing XDV do it (via plone.app.registry).

As S&D depends on plone.app.z3cform, I guess it should do it too.

Look at https://bugs.launchpad.net/singing-dancing/+bug/757406 for a traceback; I marked that one as a duplicate.

Mike Rhodes (mike-rhodes) wrote :

I'm experiencing this with Plone 4.0.4 and S&D 0.9.6.

If it's related to p.a.registry, then the issue is probably related to my installing plone.app.caching which pulls in p.a.registry. I can confirm that my dev install, without p.a.caching installed, does not have this issue.

Alex (pilz) wrote :

For me the problem is solved when updating plone.app.z3cform from 0.5.0 to 0.5.5.

Hanno Schlichting (hannosch) wrote :

This should be fixed with the 0.9.9 release.

Changed in singing-dancing:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments