Cannot set brightness or contrast

Bug #669820 reported by Alessio Treglia on 2010-11-02
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Simple Scan
Fix Released
Wishlist
Unassigned
simple-scan (Debian)
Fix Released
Unknown
simple-scan (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: simple-scan

Please allow users to set brightness and contrast.

Originally report is available at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=602064

Related branches

Changed in simple-scan (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
status: Triaged → Confirmed
Changed in simple-scan:
status: New → Confirmed
Changed in simple-scan (Debian):
status: Unknown → Confirmed
Changed in simple-scan (Ubuntu):
status: Confirmed → Triaged
Andy Clayton (q3aiml) wrote :

Hi,

I implemented this as simply two additional options under preferences. Code has been added as a related branch (lp:~q3aiml/ubuntu/maverick/simple-scan/brightness-and-contrast). Any feedback, otherwise any possibility for a merge?

Robert Ancell (robert-ancell) wrote :

Hi Andy,

Thanks for the patch. Some feedback:
- Does your scanner support these options? Could you provide the output of simple-scan -d when running it? (To see what numbers your driver expects).
- You should only set the setting if it's not the default - otherwise leave it to the driver to choose
- The GUI should have sliders, not numbers (i.e. "darker ----|----- lighter")
- The selected value should be scaled to what the driver expects. e.g. a driver might have a contrast setting from 0-100, or -100 to 100. We need to see how most drivers behave. (This is why it's important not to set the value if it's not configured - 0 might be 0 contrast, or default contrast).

I'm a little worried about how consistent drivers are with these settings, but I support the patch if it works. This setting will be "advanced" as most users will adjust the brightness/contrast after the scan is completed.

Changed in simple-scan:
status: Confirmed → Triaged
importance: Undecided → Wishlist
Michael Nagel (nailor) wrote :

to stop regressions there should probably be a checkbox to disable sending those commands to the scanner.
alternatively the slider might have a "neutral" position that also supresses the commands as described by Robert.

Andy, are you still working on this one?

Andy Clayton (q3aiml) wrote :

Hi Robert (and Michael),

First, thanks for the original review so long ago. I finally had a chance to look at this again, and I think I have fixed all the issues you pointed out. I've proposed the new branch for reviewing/merging. The point about the values that scanners expect differing makes sense, so I implemented scaling for the values. I thought I based the original range off of what mine expected, but apparently not as that turns out to be -127 to 127. Anyways, as long as no scanners expect extremely large values, the scaling should work. It now only sets the value if it is changed from default as you mentioned, so there is always that to fall back on.

Lastly, as part of the change from gtk2 to gtk3 it looks like the trough-side-details property was dropped (http://git.gnome.org/browse/gtk+/commit/?id=658f99b8eef2805f2f4ca18c9436931e8d225b26), so I don't think I can fix it drawing the misleading background highlighting anymore for the scales. I looked to see if there was a way to tell it to draw the highlight/fill from the middle, but I couldn't find anything. Setting the fill level to 0 was ignored. Setting the fill level to full would work, but then the entire background is orange and it somewhat sticks out. Oh well, I guess.

Michael Nagel (nailor) wrote :

Thanks for the update, Andy. I am really busy right now, but I will check it out soon. Best Regards

Changed in simple-scan:
status: Triaged → Fix Committed
Changed in simple-scan (Ubuntu):
status: Triaged → Fix Committed
Robert Ancell (robert-ancell) wrote :

Fixes in 3.7.1

Changed in simple-scan:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 3.8.0-0ubuntu1

---------------
simple-scan (3.8.0-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1181896)
    - Autosave document and restore on quit
    - Add controls for brightness and contrast (LP: #669820)
    - Fix scan no longer working after an ADF scan completes
    - Use GLib 2.32 threading API
    - Fix erroneous warning about failing to set ADF source
    - Updated help
    - Simplify build system
  * debian/patches/01-zlib.patch: Dropped, zlib now has a pkg-config file
  * debian/control:
    - Added libsqlite3-dev as a dependency
    - glib dependency now requires >= 2.32
 -- Matthew Fischer <email address hidden> Sun, 19 May 2013 20:02:39 -0600

Changed in simple-scan (Ubuntu):
status: Fix Committed → Fix Released
Changed in simple-scan (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.