page size setting is broken, use it as default crop or fix it by other means

Bug #550856 reported by ramaza on 2010-03-29
304
This bug affects 72 people
Affects Status Importance Assigned to Milestone
Simple Scan
Fix Released
Medium
Robert Ancell
3.10
Fix Released
Medium
Robert Ancell
3.11
Fix Released
Medium
Robert Ancell
simple-scan (Ubuntu)
Medium
Robert Ancell
Saucy
Medium
Robert Ancell
Trusty
Medium
Robert Ancell

Bug Description

For some SANE drivers simple scan always scans the largest scan area ignoring the "Page Size" setting in the preferences.

To reproduce:
1. Open Simple Scan
2. Set page size in Document > Prefrences > Page Size, e.g. to "4x6"
3. Scan a document
Expected result:
The document is scanned at the requested size
Observed result:
The document is scanned at the maximum size

Regression potential:
Low. The fix was to set the page size using an alternative method for drivers that do not support the page-width, page-height options. There is a small chance that these settings might change behaviour / expose bugs on drivers that were previously working.

ramaza (ramaza) on 2010-03-29
summary: - Automatic cropping for ADF scans
+ Automatic cropping of ADF scans

Hi ramaza,

Thanks for the bug report.

Are you suggesting that the crop should be automatically set to the page size?

Changed in simple-scan:
status: New → Incomplete
ramaza (ramaza) wrote :

At the moment the scanning process for 2 A4 pages is like this:
   1. Scanning all pages
   2. Cropping every page separately to A4
   3. Moving the cropping area on every page to the upper left corner

Much more comfortable for everyday use would be:

   1. Setting the page size in the settings (this already exists)
   2. Scanning all pages
   3. They are automatically cropped

(note you can set the crop before and during the scan and it is automatically copied to each new page).

Thanks for the bug report!

Changed in simple-scan:
status: Incomplete → Triaged
importance: Undecided → Wishlist
summary: - Automatic cropping of ADF scans
+ Use page size in settings as default crop
ramaza (ramaza) wrote :

I have forgotten one important thing:

With my scanner (HP Laserjet 3055) I have to move the crop area at the top middle. Not very comfortable doing this for every page and without zooming it's not possible to move it to the exactly correct position. I am sure this is also true for other scanners with ADF.

This is why I suggested a predefined testpage to automatically calibrate simple scan.

With this testpage it's furthermore possible to automatically correct the tilt of the ADF.

tags: added: size
Martin Wildam (mwildam) wrote :

For all those searching for a workaround: gscan2pdf by tendency works better, but anyway I have a client where that either does not work well. But give gscan2pdf a try, if you run into this issue.

This same bug seems to be reported a few different ways. The way I would describe it is: Simple Scan always produces Legal-sized pages, even when I set the page size to Letter. It is extremely frustrating, and I probably can't use the app until this is fixed.

Keith Nasman (keithnasman) wrote :

This annoys me as well. I'd be happy with it using the default page size for its initial crop setting and then when you center it on the first page, all the remaining pages center to the same spot. And then any movement of the crop for subsequent pages only effect that page. For sheet feeder scanners the positioning should always be the same when scanning a stack of paper.

Couldn't the contents of the scan be auto-detected by difference from the background?

Ali Shtarbanov (ametedinov) wrote :

Many of the features requested above are already available in Simple Scan and that was mentioned in comment #3 above. Let me elaborate on what was meant in that comment.

1. Perform a single scan
2. Crop the scan as desired
3. Scan of the next item/page/photo
4. Your second scan now has the same crop frame you set in step 2
5. All scans that follow will have the same crop frame until you change the position or size of the frame

DrKay (dr-jameskay) wrote :

@Ali

You are correct: SimpleScan has improved greatly! Now we don't have to manually crop every page of a scan, only the first page. Additionally, SimpleScan is the best scanning option for Ubuntu.

It would be more ideal for those who scan often to be able to set the preferred crop and not have to re-set it every time we do a scan (or have the crop auto-detected). This is because (1) we usually use the same scanner, (2) the page size is almost always the same (in my case, US Letter), (3) the positioning of the page on the scanner is almost always the same (if flatbed, the page is positioned in one corner of the scanner, and sheet-fed scanner also always has the same position). Also, many users will not set the crop on the first page because it is not obvious to new users that they must crop before they scan, and many users who know that they can crop before scanning forget to. If they scan without cropping, then there is no way to go back and crop all the pages that they just scanned at once, so they have to decide to either re-scan or go back through and manually crop every single page.

For occasional scanning, SimpleScan is great, but for scanning lots of documents, or documents with many pages, having to re-crop every time we scan is cumbersome. SimpleScan would be more ideal if a preferred crop could be set and remembered every time we use it, or if the cropping could be auto-detected. Being able to "bulk" crop a document after scanning would be very useful as well.

Agree with @DrKay:

(1) It would be nice if the crop used by Simple Scan was from the setting at "Document > Preferences > Page Size". (As is, I don't see that this setting does anything at least with my HP scanner.)

(2) The initial crop position is also an issue. Simple Scan centers the crop selected via "Page > Crop" which is the wrong position for my HP scanner for which the position should be top / left since that is how the hardware is intended to be used in flatbed mode and that is the position when the feeder is used. Perhaps "crop position" should be another choice at "Document > Preferences".

My daughter just used Simple Scan for the first time and I had to walk her through these two items. Sure she would have figured it out on her own after scanning the same document a few times and exploring the settings but I don't think that is the point of "Simple Scan".

Ali Shtarbanov (ametedinov) wrote :

Yesterday, I read all of the open bug reports and found several related to the cropping functionality in simple scan. I also opened one request which you may be interested in following as well. https://bugs.launchpad.net/simple-scan/+bug/1023746

Ali Shtarbanov (ametedinov) wrote :

NOTE: In my report to which I linked above, I talk about bug #685450 being similar to what I was requesting. Bug #685450 is not this bug. It is this one https://bugs.launchpad.net/simple-scan/+bug/685450

ramaza (ramaza) wrote :

Why are such simple bugs are handled so complicated and longsome???

Activate the default page size in the settings menu which exists since years.

Or make an even better and user friendly solution:
Set the cropping size and position and press a "set default cropping" button.

Isn't that easy and user friendly?

Michael Nagel (nailor) on 2012-07-22
summary: - Use page size in settings as default crop
+ page size setting is broken, use it as default crop or fix it by other
+ means
Michael Nagel (nailor) wrote :

ramaza: This is how things work with community-driven open source projects.
Maybe someone steps forward for whatsoever reason and fixes it.

However, obviously no knowledgeable person was motivated enough to fix it as of yet. If this problem really bothers you a great deal, I will gladly help you to figure out what it takes to get someone knowledgeable motivated.

In the meantime please remember that the mere existence of a bug report like this will probably not motivate anyone.
It focuses discussion and we can do our best to make it helpful to someone motivated.

Petri Salmela (pesasa) wrote :

Very annoying bug.

I need to scan a4 papers. (In Finland a4 is what we use.) However SimpleScan defaults for Letter paper, which is too wide and too short.

(1) SimpleScan should use the setting given in preferences. That's why it is there.
(2) Cropping after scanning does not help, since scanned page is too short. In x-direction cropping works, since Letter is wider than a4, but you can not crop the page to be longer than the scanned image.

Paulo Matos (pmatos) wrote :

Where's the code for this project?

ralphl (lachenmaier) wrote :

I just want to support all those that say that simplescan should crop at the page size set in Preferences. I don't like having to manually crop.

My problem is really better described here <https://bugs.launchpad.net/simple-scan/+bug/611036>
But that bug is marked as a duplicate of this bug, so I'll comment here.

I'm using Simple-scan 3.4.1 on Fedora 17. My scanner is a Brother DCP-7065DN, using the Brother proprietary brscan4 driver over ethernet.

I just scanned a page using the ADF. I had told Simple-scan to use "letter" size. Still, the resulting page is 8.27" x 13.99" according to evince.

Others report different undesired sized. Where does Simple-scan come up with these default sizes?

If we have to crop to get standard sizes (not really sensible, but what we've got, apparently), it would be nice if the cropping made those standard sizes easy. Perhaps notches in the rectangle for the standard measures. Or a choice of built-in standard sizes.

Alf Haakon Lund (alf-c) wrote :

Simple Scan 3.6.0 on Ubuntu Studio 12.10 (32-bit).

Like many others, I want simplescan to crop at the page size set in Preferences. I also want an option to apply chosen crop to multiple pages.

I'd like to add that manual crop to A4 seems to produce page size 211 x 297 mm, where it should really be 210 x 297 mm.

Michael Nagel (nailor) wrote :

i do not see any real progress here. i suggest to add some "printf"-style-debugging statements to all code intended to pull in page-size-related settings, so we can see where things fail.

Alf Haakon Lund (alf-c) wrote :

Elaborating a bit on my previous comment:

With Simple Scan 3.6.0 on Ubuntu 12.10, setting page size in preferences doesn't affect the size of a scanned document. Regardless of this setting scanning and saving produces a document 216 x 297 mm

This means the title above "page size setting is broken" is confirmed on my side as a bug.

I don't think this bug should be tagged as "wishlist" either, this is not a feature request, but a report of unexpected (and unwanted) behaviour.

Michael Nagel (nailor) on 2013-04-16
Changed in simple-scan:
importance: Wishlist → Medium
Paul (ep42) wrote :

And here's one more. Same on Ubuntu 12.10 with a Canon LiDE 60. Page size settings are not respected. Sorry, but that's a basic feature and should not be set to 'Medium'.

I added comment #20. Now I'm reporting similar misbehaviour on a different system.

My wife observes that with our Fujitu fi-6130 Sheetfed Scanner Ubuntu 12.04 LTS + updates, setting the pages size, and using the Automatic Document Feeder yields a page size unrelated to the page size. If you then discard that set of scans and scan again, the page size will be correct!

This workaround is practical because the scanner is quick.

But, really, how can this stupid a bug persist for three years!

Colan Schwartz (colan) wrote :

If you folks really want it fixed sooner, I'd recommend putting some money towards it by starting a bounty over at http://www.cofundos.org/, http://www.fossfactory.org/ or any similar sites listed at http://alternativeto.net/software/cofundos/.

Colan Schwartz (colan) wrote :

...and then please post the URL for it in here. :)

Tony Whelan (tony-whelan) wrote :

My Brother DCP-7065DN MFC produces scans that are Legal/Foolscap size despite the page size being set at A4.

The faulty page size only occurs when using the automatic document feeder. Scans of a page laid directly on the glass are correctly sized.

So somehow the page size setting gets ignored by the ADF.

Tony Whelan (tony-whelan) wrote :

A lot of the reports above do not say whether their problem only occurs when using an ADF, but I suspect that is the case.

Since some people report getting a different size page to what I am getting (Legal), the resultant size might depend on the particular brand/make of scanner Automatic Document Feeder.

I have no idea how to make sense of the source code for this application, and would be even more baffled if I looked at a proprietary scanner driver.

But I notice that if I run xsane instead of simplescan, it sees my scanner and displays the text "21.59 x 35.56cm" at the bottom of the main dialog near the Scan button. That size is Legal (8.3" x 14") so it seems that both xsane and simplescan read that from the device driver somehow.

@Tony, #28 and #29

Thanks: you taught me something. My DCP-7065 can scan legal-sized paper through the ADF. I just assumed that since the flatbed maxed out at A4 length that the ADF would be the same.

Here are a couple of experiments done on DCP-7065dn with simple-scan-3.8.0-1.fc19.x86_64 and brscan4-0.4.1-3.x86_64.

- all ADF scans on DCP-7065 come out 8.27 × 13.99 in, which is slightly narrow for legal (8.5 x 14) but the right length. Mucking with the paper size prefs had no effect.

- all flatbed scans come out 8.27 × 11.46 inch (according to evince). A4 is 8.27 × 11.69 and Letter is 8.5 * 11. So I'd say that it is always scanning slightly truncated A4. Mucking with the paper size prefs had no effect.

When starting a scan, the blank page in the window is of the size of the last scan. As the scan starts, the page image resizes.

Next experiment: same computer, but Canon CanoScan LIDE 20 flatbed scanner (with open source SANE driver). This theoretically supports A4, Letter, and smaller, but no Legal. All scans, no matter whether prefs are set to A4 or Letter, come out 8.46 × 11.69 inch. Seems like the width of Letter (larger than A4) and the length of A4 (larger than Letter).

I hope to try more experiments with other scanners, but that's it for now.

Gaëtan André (gaetan-andre) wrote :

It definitely a bug. Default scanner size is not taken into account.

I scan A4 pages and I have a higher page (filled with blank). I have the same problem with another GTK based application called Paperwork.

One could suspect the problem coming from the linux drivers, or from the common scanning lib. But the problem does not show up with xsane ...

Benjamin Sperisen (lasindi) wrote :

I can confirm this also occurs with my ADF HP Officejet 4315xi All-in-One scanner. The setting is saved even if I quit and restart Simple Scan, but all my documents are much too long even if I select "Letter" and scan a letter-sized page. It really is surprising this bug has lasted so long....

Also, this does NOT happen when I scan using XSane, so it appears specific to Simple Scan and not the driver.

Robert Ancell (robert-ancell) wrote :

Benny sent a log after this problem occurred for him (thanks Benny!). His scanner didn't provide the page-width and page-height options so simple-scan was unable to set the page size.

I have a candidate fix in lp:~robert-ancell/simple-scan/scan-size.

If you are capable please try building from this branch and see if it fixes the problem. The following instructions will allow you to do this on an Ubuntu system:

$ bzr branch lp:~robert-ancell/simple-scan/scan-size simple-scan-fix
$ cd simple-scan-fix
$ sudo apt-get build-dep simple-scan
$ ./autogen.sh --prefix=$PWD/install
$ make
$ ./src/simple-scan

Robert Ancell (robert-ancell) wrote :

Also attaching logs will help - the log is stored in ~/.cache/simple-scan/simple-scan.log. Copy it after doing a scan with the problem and quitting simple-scan.

Tony Whelan (tony-whelan) wrote :

Attached is the log after scanning an A4 page via the ADF on a Brother DCP-7065DN using Simple Scan on Linux Mint 15.

(The scanned document ended up as Legal size instead of A4.)

I've edited out the umpteen identical lines in the log so as to make it easier to read.

Benjamin Sperisen (lasindi) wrote :

I just built and tried Robert's branch and it fixes the problem on my system -- thanks Robert!

Robert Ancell (robert-ancell) wrote :

Tony, your log shows the same issue that Benny had. I'm going to go ahead an close this bug assuming this is the common problem everyone here has. Please open a new bug if you still have the problem once 3.11 is released.

Changed in simple-scan:
status: Triaged → Fix Committed
Changed in simple-scan:
status: Fix Committed → Fix Released
milestone: none → 3.11.1
Changed in simple-scan:
milestone: 3.11.1 → none
Changed in simple-scan (Ubuntu Saucy):
status: New → In Progress
Changed in simple-scan (Ubuntu Trusty):
status: New → Fix Released
Changed in simple-scan (Ubuntu Saucy):
importance: Undecided → Medium
Changed in simple-scan (Ubuntu Trusty):
importance: Undecided → Medium
Changed in simple-scan:
assignee: nobody → Robert Ancell (robert-ancell)
Changed in simple-scan (Ubuntu Saucy):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in simple-scan (Ubuntu Trusty):
assignee: nobody → Robert Ancell (robert-ancell)
description: updated
Tony Whelan (tony-whelan) wrote :

Many thanks Robert

I haven't been able to test the fix yet but hopefully this will do the trick.

Tony Whelan (tony-whelan) wrote :

Just tested Robert's branch on my test machine (Ubuntu Saucy 64 bit).

When I set the page size to A4 in Simple Scan, then put some A4 pages in the ADF, Simple Scan correctly renders them as A4.

Thank you Robert!

Hello ramaza, or anyone else affected,

Accepted simple-scan into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/simple-scan/3.10.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in simple-scan (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

The page size setting is honored by the proposed version, thank you for the fix!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simple-scan - 3.10.2-0ubuntu1

---------------
simple-scan (3.10.2-0ubuntu1) saucy; urgency=low

  * New upstream release:
    - Install missing help images (LP: #1211148)

simple-scan (3.10.1-0ubuntu1) saucy; urgency=low

  * New upstream release:
    - Fix page size not being applied on some drivers (LP: #550856)
    - Rewrite autosaving. Now uses files for scan data, is more efficient in
      writing to disk and drops dependency on sqlite. (LP: #1245678)
  * debian/control:
    - Drop build-depends on libsqlite3-dev
 -- Robert Ancell <email address hidden> Fri, 01 Nov 2013 12:42:30 -0700

Changed in simple-scan (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for simple-scan has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

manojav (manojav) wrote :

This is still broken on my HP Scanjet 5590. The Pages start bleeding on the next page, and it by the time it gets page number 10 or so the offset is almost half a page. I have to set my page height to 28.3 cm (Letter) in XSane and it works perfectly.

manojav (manojav) wrote :

Sorry I should add this problem is still apparent only when scanning Front and Back of a page. Doest not exist when I scan Front's only or Back's only.

manojav (manojav) wrote :

Attached is a sample of the page bleed on a duplex (front/back scan) . Again the same duplex scan works on XSane with page length set to 28.3. Maybe add the ability to provide a custom page length instead of hard coding it Letter size would be nice. I know it goes against the simple scan principles but that could be a quick fix.

manojav (manojav) wrote :

This was performed on 3.11.1.1 on Ubuntu 13.10.

manojav (manojav) wrote :

Sorry for the many comments, but this occurs during a duplex scan on ADF.

Robert Ancell (robert-ancell) wrote :

manojav - please open a new bug for duplex page size problems and attach ~/.cache/simple-scan/simple-scan.log after performing a scan.

Charles (clmoore3rd) wrote :

Changing page size is still broken with Software Center release version simple-scan 3.12.1-0ubuntu1 and Ubuntu 14.04.
When legal size is selected and legal paper is fed through the ADF of a Canon ImageClass MF4150 the entire page is not scanned. The scan size is the same as if letter size was selected.

passtoor (passtoor) wrote :

Hewlett-Packard HP LaserJet Professional M1214nfh MFP
Ubuntu 14.04.4

Sylvain Viart (sylvain-viart) wrote :

I got it in xubuntu 16.04.1 fresh install with Brother DCP-J715W
simple-scan version 3.20.0

I want A4 page size, and simple-scan is displaying a bigger page size.

Setting in preferences doesn't change the page. (quit + restart)

starting up simple-scan from shell in debug mode (-d)
Gives me a path ~/.cache/simple-scan/state

I remove this file and restarted simple-scan and page size seems now OK.

cat ~/.cache/simple-scan/state
[window]
width=600
height=400
is-maximized=false
is-fullscreen=false

[last-page]
width=2480
height=3506
dpi=300
scan-direction=top-to-bottom

May it helps…

Ben (7-ben-a) wrote :

Sylvain, I had the same issue recently (before it worked well) and your workaround did the job! However, I had to change page size once after restart from "A4" to "automatic" to take effect (changed it back then to A4). Thanks a lot!

Ben (7-ben-a) wrote :

Update: When I startup my PC the setting in the file ~/.cache/simple-scan/state is

[window]
width=600
height=400
is-maximized=true
is-fullscreen=false

[last-page]
width=1240
height=1750
dpi=300
scan-direction=top-to-bottom

The displayed, empty page in simple scan is A4. Now I put in one A4 page and start the scan via "CTL-F". During the scanning the page size shrinks and after finishing the scan the file content changed to

heigh=1650.

This happens every time after an upstart of the PC. I can then set from "A4" to "automatic", scan once and the right size comes up.

However, when shutting down the PC, this setting ("automatic") is going to be loaded upon a fresh start. Then, the same thing happens (size is correct, during scan it gets cropped). But now I have to change to another size ("A4" for example) and then scan and then change to "automatic" and scan to get the right size.

This is awkward and unnerving.

Please can someone help to fix this? I absolutely love simple scan and use it every day!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions