Documentation cannot be translated

Bug #543282 reported by ubuntu user
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Simple Scan
Fix Released
High
Robert Ancell
Ubuntu Translations
Medium
Unassigned
simple-scan (Ubuntu)
High
Unassigned

Bug Description

There is no possibility to translate simple-scan's documentation in any way whatsoever. Neither the Lucid package, nor the upstream package have a template available for translating the documentation.

on https://translations.launchpad.net/simple-scan two pot files should show up:
- po/simple-scan.pot
- help/simple-scan-help.pot

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Not sure why this is, the documentation is marked for translation like any other GNOME project. Could it be because there is nothing set in DOC_LINGUAS? (i.e. no upstream translations)

Changed in simple-scan:
importance: Undecided → Medium
status: New → Triaged
importance: Medium → High
Changed in simple-scan (Ubuntu):
status: New → Triaged
importance: Undecided → High
Revision history for this message
Gabor Kelemen (kelemeng) wrote :

I didn't looked in it yet, but there is no pot file in the import queue for docs. This indicates that the most probable reason is that at package build time the pot file is not generated for docs.

Revision history for this message
Aron Xu (happyaron) wrote :

Hi,
For most time docs of single application are blocked in Ubuntu import queue, because language packs only ship the UI translations but not docs, those translations should be done separately in upstream project. For simple-scan, I suggest setting up doc translations in simple-scan project in Launchpad, so that translators can manage to translate it.

Regards,
Aron Xu

David Planella (dpm)
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
ubuntu user (gplx1111) wrote :

Has any progress made on this bug?

Revision history for this message
Michael Nagel (nailor) wrote :

I asked on #ubuntu-translators, and Robert, can you try what they suggest:
(21:56:54) kelemengabor: also, on the simple scan thing, I think someone should commit the documentation pot template as help/simple-scan-help.pot, and then LP should be able to pick it up
(21:57:31) kelemengabor: given that it is set to Import template files on the /trunk/+translations-settings page

Full log for your reference:

Conversation with #ubuntu-translators at Fr 25 Nov 2011 21:21:37 CET on <email address hidden> (irc)
(21:21:38) #ubuntu-translators: The topic for #ubuntu-translators is: ...
(21:21:38) List of 27 users: ...
(21:24:51) Michael Nagel: can someone help me with https://bugs.launchpad.net/ubuntu/+source/simple-scan/+bug/543282
(21:24:53) ubot4: Launchpad bug 543282 in simple-scan (Ubuntu) (and 2 other projects) "Documentation cannot be translated (affects: 2) (heat: 14)" [High,Triaged]
(21:25:27) Michael Nagel: what can be done so that translation of the documentation can be created?
(21:35:45) andrejz: hello nailora. I think it's best to contact simple-scan team and ask them about it
(21:36:34) RobinJ1995 is now known as RobinJ
(21:37:07) Michael Nagel: robert ancell is the main (and only) developer for simple scan, and according to that bug he does not really know how to set up things
(21:37:21) Michael Nagel: can you give me a hint that i can forward?
(21:37:34) andrejz: from the comments (which are now a bit old) it seems they need to at least generate a .pot file
(21:37:59) andrejz: hm, i am not the technical guy here ;)
(21:38:05) andrejz: kelemengabor, are you there?
(21:38:15) andrejz: your skills would be appriciated
(21:44:51) kelemengabor: re
(21:45:31) andrejz: how to enable translations for simple scan docs?
(21:46:01) kelemengabor: umm, good question
(21:47:00) andrejz: kelemengabor i was also wondering if you are aware of some nice technical resources about .po file translation mechanism somewhare
(21:47:07) andrejz: i would to understand the background a little bit better
(21:47:36) kelemengabor: mechanism? how about the gettext manual?
(21:47:45) kelemengabor: http://www.gnu.org/software/gettext/manual/gettext.html
(21:48:02) kelemengabor: pretty comprehensive, if you ask me :)
(21:48:26) andrejz: ok, i thinik this will be quite sufficient
(21:51:32) kelemengabor: yw
(21:56:54) kelemengabor: also, on the simple scan thing, I think someone should commit the documentation pot template as help/simple-scan-help.pot, and then LP should be able to pick it up
(21:57:31) kelemengabor: given that it is set to Import template files on the /trunk/+translations-settings page
(22:03:37) Michael Nagel: ok i will forward that info to the bug
(22:03:42) Michael Nagel: thanks
(22:06:12) kelemengabor: also this may be helpful too: https://help.launchpad.net/Translations/ImportingFromBazaarBranches
(22:08:07) kelemengabor: nailora: thanks for bringing this up/pushing forward, this is definiately something I'd like to see sorted out before Precise :)

Revision history for this message
Michael Nagel (nailor) wrote :

(09:41:58) Michael Nagel: anyways: Documentation cannot be translated https://bugs.launchpad.net/ubuntu/+source/simple-scan/+bug/543282 -- nobody seems to really know how to proceed. any idea?
(09:43:00) robert_ancell: nailora, no idea, but I'll try kelemengabor's suggestion
(09:43:23) robert_ancell: I think it's simpler now we use the new documentation system

Changed in simple-scan:
assignee: nobody → Robert Ancell (robert-ancell)
Revision history for this message
Robert Ancell (robert-ancell) wrote :

OK, I copied what Deja Dup did [1] and hopefully it will now work...

[1] http://bazaar.launchpad.net/~deja-dup-hackers/deja-dup/24/view/head:/help/Makefile.am

Changed in simple-scan:
status: Triaged → Fix Committed
Changed in simple-scan (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Gabor Kelemen (kelemeng) wrote :

Somethign went wrong with this in upstream. Now the usual ui template is replaced with the template of the help: https://translations.launchpad.net/simple-scan/trunk

There should be two templates, and in bzr too.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Argh!

po/simple-scan.pot was no longer committed as LP seemed to work that out itself and I'm guessing since I committed help/simple-scan-help.pot it got confused and switched to that one? I've committed po/simple-scan.pot now, so there are two committed .pot files in the branch, and hopefully LP will no work it out.

It seems help/simple-scan-help.pot is stuck in a queue?
https://translations.launchpad.net/simple-scan/trunk/+imports

Revision history for this message
Michael Nagel (nailor) wrote :

I consider this fixed, please reopen/file a new bug if there is still an issue.

Changed in simple-scan:
status: Fix Committed → Fix Released
Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in simple-scan (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Gabor Kelemen (kelemeng) wrote :

There is still something wrong: https://translations.launchpad.net/simple-scan lists only one template to translate, there should be two.

Revision history for this message
Jiri Grönroos (jiri-gronroos) wrote :

@ 10, Nailor, could you explain why you consider this bug as fixed?

The pot file for help was commited three months ago - http://bazaar.launchpad.net/~simple-scan-team/simple-scan/trunk/revision/574

As mentioned by Gabor, the help file isn't translatable via LP translation web UI.

Revision history for this message
Michael Nagel (nailor) wrote :

I considered it fixed because the pot file Robert mentions in #9 is no longer stuck in a queue.
The latest two comment show that this was not the root issue and there is still a problem.

Is anybody knowledgeable about the translation setup?

Changed in simple-scan:
status: Fix Released → Confirmed
description: updated
Revision history for this message
Michael Nagel (nailor) wrote :

I think I found out who might be able to help us.
Could you (Gabor, Jiri, ...) please provide the information requested at
https://answers.launchpad.net/launchpad/+question/203651

I think it is the main template, but I am not so familiar with the translation interface and you can tell for sure.

Revision history for this message
Michael Nagel (nailor) wrote :

Gabor, Jiri: it seems to work now, please confirm!

best regards
michael

Revision history for this message
Jiri Grönroos (jiri-gronroos) wrote :

It does work now. Thank you for your efforts.

Changed in simple-scan:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers