Edit view on Silva link are broken when they are published

Bug #273102 reported by Sylvain Viollon on 2008-09-22
2
Affects Status Importance Assigned to Milestone
Silva
Critical
Sylvain Viollon

Bug Description

If you create a Silva Link to http://www.google.com, and publish it in Silva 2.1, when you can't access to the edit view anymore.

This is due of the preview on the edit view we think.

Sylvain Viollon (thefunny) wrote :

It's seems to come from the preview changes you made. Can you check that ? I am going to add functional test for that after.

Changed in silva:
assignee: nobody → aaltepet
importance: Undecided → Critical
status: New → Confirmed
milestone: none → 2.1.1
Andy Altepeter (aaltepet) wrote :

Sylvain, I'm not able to reproduce this using a fresh buildout of the Silva 2.1 branch.

I create a new silva document, and add a link to http://www.google.com. I then save and publish the document. The edit screen is not broken, and I see a preview of the document below the matrix navigation. Could you post the traceback?

Changed in silva:
assignee: aaltepet → sylvain
assignee: sylvain → thefunny
Sylvain Viollon (thefunny) wrote :

There is no traceback, you are just redirected to Google. However, you don't add a Silva Document but a Silva Link (that's Silva Link which is broken).

Changed in silva:
assignee: thefunny → aaltepet
Andy Altepeter (aaltepet) wrote :

Sylvain, I tried to replicate this using a buildout of the Silva 2.1 branch, and one from the trunk. I did the following:

1) in the Silva root, I added a silva link
id: link
title: link
type: absolute
url: http://www.google.com
2) I "save and edited"
3) I published
4) I saw the edit tab displaying the following: Link <<link>> redirects to: http://www.google.com

I also tried creating a relative link, and it had the same behavior as I describe above.

Looking in the source, I see the Silva/install.py registers a preview view for Silva Links, which is: views/public/SilvaLink/preview/render.py

It explicitly tests to see whether we are in the edit screen (and not the preview tab), and if so returns the text described above. Perhaps you could verify that the preview view for SilvaLInks in your instance are going registered properly?

I wonder if anyone else at infrae is able to replicate the behavior in this bug report.

Changed in silva:
assignee: aaltepet → thefunny
Andy Altepeter (aaltepet) wrote :

I don't think this is really an issue.

Changed in silva:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers