error diagnostics registry/UI for errors

Reported by Martijn Faassen on 2003-01-30
18
Affects Status Importance Assigned to Milestone
Silva
Low
Guido Wesdorp

Bug Description

In some cases, we get errors which are easily diagnosed by
looking at the exception type and string and
which may recurr in multiple releases. The best candidate of
this is the UnicodeError. Unauthorized is another (but more
complicated) example.

In this case, it is more user friendly to present a better
diagnostic than just the traceback. In case of unicode
errors this could for instance be something like (VERY
rough draft):

  Text handling problem. Silva received some characters
  it could not deal with for some reason. This is very
  likely to be a bug we would like to hear about.

  [button] presents an email message with diagnostic
  information which you can send to the developers through
  <email address hidden>. Please describe what you were doing
  at the time (were you editing? previewing? What element
  did you change just before the error occured?)

In case of unauthorized we already intercept and display
a link to request authorization. In some cases this could
be due a bug in Silva however, so we should mention
something about this as well.

We need to handle this on an error by error basis; some
errors it is very hard to provide sensible diagnostics
about (think IndexError for instance), except that it
"it is an error". But in other cases this could help the
user experience and provide us with more information.

Martijn Faassen (faassen) wrote :

We need to start experimenting with this soon if we
want to make 0.9.2. Guido, interested in this? It
involves a registry. ;)

Guido Wesdorp (guido-infrae) wrote :

Did you just mention the magic word? :)

Guido Wesdorp (guido-infrae) wrote :

Just a thought: how would this fit in with i18n?

Martijn Faassen (faassen) wrote :

Okay, moving this post 0.9.2, as I think this hasn't started yet.

Martijn Faassen (faassen) wrote :

Moving along to Silva-0.9.4. We *may* be able to have enough time in
Silva-0.9.3 but I'm not counting on it..

Kit Blake (kitblake) wrote :

Adding the point that - whatever the solution becomes - it should include i18n
translation capability.

Sylvain Viollon (thefunny) wrote :

Technical errors are no longer shown to the user since Silva 2.3. The error log have been improved to include more information, and support for sentry is provided for professional hosting that want to fix theirs errors.

Changed in silva:
milestone: none → 2.3.6
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers