[1.0.1] KeyModifier.WIN uses alt in linux

Bug #966708 reported by Brian Parma on 2012-03-28
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Sikuli
High
RaiMan

Bug Description

I tried using type(' ', KeyModifier.WIN), I also tried .KEY_WIN, .META, and .KEY_META, but all seem to just pass Alt+whatever.

I'm trying to use it to activate WIN+r through a RDP connection. I know it's passing Alt, because I can use it to activate local hotkeys.

I'm on Linux Mint 12, using Sikuli X 1.0rc3 (r905) 64 bit.

RaiMan (raimund-hocke) on 2012-11-02
Changed in sikuli:
importance: Undecided → Low
assignee: nobody → RaiMan (raimund-hocke)
RaiMan (raimund-hocke) on 2012-11-02
tags: added: fkt-type
RaiMan (raimund-hocke) on 2013-02-21
Changed in sikuli:
status: New → In Progress
Yushu (yushu-li) wrote :

I have the same problem. I also tried to use WIN+i to enable setting on windows 2012 through rdp connection.

I tried the following:

    type("i", Key.WIN)

    type("i", KeyModifier.WIN)
    keyDown(Key.WIN) type("i") keyUp(Key.WIN)

None of them worked. It behaved like I just sent the windows home key to sikuli and it poped up the search menu in ubuntu.
Also I tried .META and KEY_META.

RaiMan (raimund-hocke) on 2013-11-14
Changed in sikuli:
importance: Low → High
milestone: none → 1.1.0
summary: - KeyModifier.WIN uses alt in linux
+ [1.0.1] KeyModifier.WIN uses alt in linux
Yushu (yushu-li) wrote :

Thanks, RaiMan. It will be helpful. I have had this problem for a while.
The automation test runs on linux (Ubuntu) and it set up a rdp connection to a windows 2012 session host. It tries to disconnect the rdp connection.

There are two ways to enable setting icon and then go to click power, and disconnect in windows 2012.

1. Hover on the right upper or right bottom of the screen, a menu would pop up with setting icon. But it's highly related with timing. The menu will disappear within 1 second or may be less than 1s. The default setting of Settings.MoveMouseDelay, Settings.WaitScanRate, Settings.ObserveScanRate are 0.5, 3, 3. I changed them to 0.01. and still sikuli couldn't find the setting icon during it shows up.
2. Hotkey to enable the menu with setting icon. I have the problem of clicking KeyModifier.WIN doesn't work well with "i" together.

RaiMan (raimund-hocke) wrote :

@Yushu
With version 1.0.1 on Windows, the Key.Win should work as expected:

type(Key.WIN) opens start menu
type("r", Key.WIN) opens the run menu
type("i", Key.WIN) opens the settings dialog (right bar on Win 8)

Yushu (yushu-li) wrote :

Thanks, RaiMan. I work on Linux. On Linux, I open a rdp session whose server side is windows 2012 and try to disconnect it on client side which is Linux. Sorry for the confusion.

Phuong Hoang (phuong-hoang-z) wrote :

Thanks Raiman for your instruction on Key.WIN hotkey. It works perfectly on Windows for me. However, when I used it inside a RDP session, the hotkeys were always applied to the client Windows machine. Is there a way to make those hotkeys applied inside the RDP window with Sikuli?

TestMechanic (ndinev) wrote :

On Linux Ubuntu 14.04 LTS following doesn’t not work with Sikuli 1.1.0

type("d", KeyModifier.WIN) # minimize all
type("r", KeyModifier.WIN) # open run menu

Any ideas what could be the problem?

TestMechanic (ndinev) wrote :

and the console says
[log] ( Windows ) TYPE "d"

[log] ( Windows ) TYPE "r"

RaiMan (raimund-hocke) on 2016-03-28
Changed in sikuli:
milestone: 1.1.0 → 1.1.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers