X-1.0rc3: IDE: sikuli start hangs after first try

Bug #851833 reported by Ales Katona
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SikuliX
Critical
RaiMan

Bug Description

******* possible reason and workaround

This might happen due to bugs in the new session save feature (at restart: restore IDE window and reopen files, that have been open when quitting IDE before)
see faq 1766

additionally there seems to be a bug, that after using File -> Open, the tab is named "Untitled" until you save it again. If you quit the IDE in this situation, you are in the above restart problem ("Untitled" cannot be reloaded).

So for now, until these bugs are fixed:
When quitting the IDE, make sure, that all tabs are closed - do not leave any files open.

---------------------------------------------------------

Sikuli version RC3, Linux x64 (Ubuntu 11.04)

RC2 works fine, but in RC3 the IDE just doesn't start on subsequent tries. I open the IDE, load an existing script, run and quit. Then when I want to run the IDE again I get nothing. Running from command line just shows "[info] locale: en_US" and doesn't go anywhere from there.

It's probably a locale related problem because in RC2 the line shows "sk_SK" (which is right) and just tells me no info for given locale. In RC3 it shows "en_US" (not right) and hangs.

Revision history for this message
Tsung-Hsiang Chang (vgod) wrote :

Can you change a parameter -Dsikuli.console to false in sikuli-ide.sh and run it again? This may tell us more messages about the error.
Thanks!

Changed in sikuli:
status: New → In Progress
Revision history for this message
Ales Katona (almindor) wrote :

The backtrace is:

[info] locale: en_US
Exception in thread "main" java.lang.NullPointerException
 at org.sikuli.ide.ImageButton.createFromString(ImageButton.java:241)
 at org.sikuli.ide.SikuliPane.replaceWithImage(SikuliPane.java:617)
 at org.sikuli.ide.SikuliPane.parseLine(SikuliPane.java:568)
 at org.sikuli.ide.SikuliPane.parseRange(SikuliPane.java:528)
 at org.sikuli.ide.SikuliPane.parse(SikuliPane.java:543)
 at org.sikuli.ide.SikuliPane.parse(SikuliPane.java:546)
 at org.sikuli.ide.SikuliPane.read(SikuliPane.java:427)
 at org.sikuli.ide.SikuliPane.loadFile(SikuliPane.java:372)
 at org.sikuli.ide.SikuliIDE.loadFile(SikuliIDE.java:838)
 at org.sikuli.ide.SikuliIDE.restoreSession(SikuliIDE.java:768)
 at org.sikuli.ide.SikuliIDE.<init>(SikuliIDE.java:713)
 at org.sikuli.ide.SikuliIDE.getInstance(SikuliIDE.java:138)
 at org.sikuli.ide.SikuliIDE.main(SikuliIDE.java:973)

This happens when I delete an image I use inside the sikuli code (not a sikuli region/capture). I use a path with my own captureScreen("path") (extension) function. The IDE crashes when the given path/image is not found it seems? I think the IDE tries to replace the path with the image from file and simply fails. For me it's not a problem atm. because I was just testing extensions and wanted to add a simple screenshotter function, but I guess these things can cause problems if people use some image paths in their scripts which are not related to the internal sikuli screenshot taker.

Revision history for this message
Ales Katona (almindor) wrote :

Perhaps a quick fix would be to not try to replace image paths for images outside the project.sikuli directory?

Changed in sikuli:
status: In Progress → Fix Committed
Changed in sikuli:
milestone: none → x1.0
RaiMan (raimund-hocke)
summary: - sikuli start hangs after first try
+ X-1.0rc3: IDE: sikuli start hangs after first try
description: updated
RaiMan (raimund-hocke)
Changed in sikuli:
assignee: nobody → RaiMan (raimund-hocke)
RaiMan (raimund-hocke)
tags: added: windows-startup
RaiMan (raimund-hocke)
Changed in sikuli:
importance: Undecided → Critical
RaiMan (raimund-hocke)
Changed in sikuli:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers