X-1.0rc2 IDE: Preview: hangs using larger images and spikes processor usage

Bug #717602 reported by RaiMan on 2011-02-12
60
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Sikuli
High
Unassigned

Bug Description

Win7, Mac

from the related question:

I've just installed and tried out the RC2, it doesn't quite work for me.
It takes forever (maybe it hangs) when I click on a image to open up the pattern settings dialog.
It'll hang there and try to finish the pattern matching. I've tried different ways to do it and still have same problem.

It works perfectly quick and fine in RC1.

my comment:

I confirm, that this happens on Win7 and on Mac:

In Preview: Only small images (< 200x200) are found after a rather long time (> 10 secs).
With larger images, it does not find and come back at all.
(all tested images are found as expected with a find())

On top, even, if you close the Preview window, the findAll process seems to run further in the background.

SMercier (smercier) wrote :

I confirm the same behavior on winxp sp3. For the a an image of 30 * 30 pixel the Finder module takes around 27 sec. The behavior is correct with the rc1.

Regards

RaiMan (raimund-hocke) on 2011-02-17
Changed in sikuli:
status: New → Confirmed
importance: Undecided → High
Changed in sikuli:
milestone: none → x1.0-rc3
RaiMan (raimund-hocke) on 2011-06-29
summary: - X-1.0rc2 IDE: Preview: hangs using larger images
+ X-1.0rc2 IDE: Preview: hangs using larger images and spikes processor
+ usage
Changed in sikuli:
status: Confirmed → Fix Committed
RaiMan (raimund-hocke) on 2011-09-27
Changed in sikuli:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers