X-1.0rc2: find().click(): 2nd arg of click() not optional

Bug #583090 reported by Edu on 2010-05-19
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Sikuli
Undecided
Unassigned

Bug Description

*** bug still valid with X-1.0rc2

Calling click on a Match object requires a modifier as second argument:

find(img1).click(img2, 0)

The following does not work:

find(img1).click(img2)

TypeError: click(): expected 2 args; got 1

But this does:

Region(find(img1)).click(img2)

According to the documentation, Match is a subclass of Region and therefore the modifier argument for click should be optional.

The problem is that find(img1) returns an instance of edu.mit.csail.uid.Match, whereas Region(find(img1)) is a class instance of sikuli.Region.Region.

Sikuli version: 0.10.0
OS version: Windows XP SP3

Edu (karlmicha) on 2010-05-19
tags: added: 0.10
Changed in sikuli:
status: New → Confirmed
RaiMan (raimund-hocke) on 2011-05-16
summary: - Second argument not optional when calling click on a Match object
+ X-1.0rc2: find().click(): 2nd arg of click() not optional
description: updated
Changed in sikuli:
status: Confirmed → Fix Committed
milestone: none → x1.0-rc3
RaiMan (raimund-hocke) on 2011-09-27
Changed in sikuli:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers