Sikuli doesn't work on 64-bit operating systems

Bug #511745 reported by Tsung-Hsiang Chang on 2010-01-24
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Sikuli
Undecided
Unassigned

Bug Description

Pedram Amini and Limo Driver suggested to provide a parameter to select a different JRE for windows' .exe.

Sergey Darovskih (darovskih) wrote :

I installed 64 bit JRE and it started to work.

Olexandr Savchuk (mail-olex) wrote :

Interestingly enough, it works for me by forcing 32-bit JRE via modifiying the included batch file. Refuses to launch with 64-bit JRE. Windows 7 Professional x64.

Sikuli User (dapthar) wrote :

Olexander,

Can you show the changes you made to the batch file? Mine is shown below, just after installation.

Thanks.

@echo off
PATH=%PATH%;%~d0%~p0\tmplib
java -Dpython.path="%~d0%~p0\sikuli-ide-full.jar\Lib" -cp "%~d0%~p0\sikuli-ide-full.jar" edu.mit.csail.uid.SikuliIDE %*

Eloi (eloi) wrote :

Change the .bat file to something like below
"C:\Program Files (x86)\Java\jre6\bin\java.exe" should be the default, do a search for the x86 version of the jre java.exe.

@echo off
PATH=%PATH%;%~d0%~p0\tmplib
"C:\Program Files (x86)\Java\jre6\bin\java.exe" -Dpython.path="%~d0%~p0\sikuli-ide-full.jar\Lib" -cp "%~d0%~p0\sikuli-ide-full.jar" edu.mit.csail.uid.SikuliIDE %*

yoshi (lee-0-21) wrote :

Thanks made the changes suggested above by Eloi, and the batch file now seems to work

Roman Myers (romnempire) wrote :

Tried installing 64x Java and editing the .bat file.

Running the .exe still does nothing.

(Windows 7 x64 Professional)

any other ideas?

yoshi (lee-0-21) wrote :

Roman, running the exe does nothing for me, but run the bat file you edited... that should yield results

Roman Myers (romnempire) wrote :

i get a message that says:

redirect stdout/stderr to console

is that the normal operation, or should i get something else?

Knight Samar (knightsamar) wrote :

Yeah that also appears on Linux 32-bit. Do you get the GUI, Roman Meyers ?

Roman Myers (romnempire) wrote :

When i ran the bat file, i had changed the dir to my 64 bit version of Java, and i would only get the message, but not the Sikuli GUI.

After experimenting with a 32 bit version of windows, i found out that it is normal to get that message.
running the bat file with the path to by 32 bit Java install actually worked.

Sikuli User (dapthar) wrote :

Thanks Eloi, your edit worked for me.

Sikuli User

Changed in sikuli:
status: New → Confirmed
Michael Meng (tianbao777) wrote :

I use Ubuntu 9.10 64bit, the sikuli does not work.

Welcome 64bit for Ubuntu.

I try to build sikuli ide on my machine, but it fail.
About build, I learn from
http://i-miss-erin.blogspot.com/2010/01/automated-test-in-android-by-sikuli.html

But it fail.

JustJake (robthereverend) wrote :

Confirming the .bat file fix worked for me. 64bit Vista with 32bit Java install.
Stand-alone and installation based app both work now.

Débora (desetton) wrote :

.bat file fix worked for me too (Windows 7 x64 with x32 JRE)
Thanks Eloi and JustJake for pointing out the solution!

Renan Oliveira (renan-gpa) wrote :

Resolved in Ubuntu 9.10 64bits

Changed in sikuli:
status: Confirmed → In Progress
status: In Progress → Fix Released
status: Fix Released → Confirmed
Changed in sikuli:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions