[1.1.4] macOS 10.14: IDE does not start up --- tested with Java 11 and Java 8 --- works

Bug #1794513 reported by RaiMan on 2018-09-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Sikuli
Undecided
RaiMan

Bug Description

Does Sikuli work wih Mojave (macOS 10.14)?
I'm trying to execute the IDE, but I can't. I can see the Sikuli menu on top of the screen, but no dialog or window is displayed.

Thanks!

RaiMan (raimund-hocke) on 2018-09-26
Changed in sikuli:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → RaiMan (raimund-hocke)
milestone: none → 1.1.4

Just upgraded to macOS 10.14 and tested with Java 11:
works as it should.

So you have to revise your setup.

Changed in sikuli:
status: Fix Committed → Invalid
summary: - [1.1.4] macOS 10.14: IDE does not start up
+ [1.1.4] macOS 10.14: IDE does not start up --- tested with Java 11 ---
+ works
Changed in sikuli:
importance: High → Undecided
status: Invalid → Won't Fix
status: Won't Fix → Invalid
Teresa (wiris) wrote :

I'm working with java 8 and you're right, the IDE works. Working with java 8 it's a requirement for my development environment.
The problem is I can't take screen captures with the IDE. Does this feature work ok with java 11?

RaiMan (raimund-hocke) wrote :

Yes everything is fine, even with Java 8.

-- 8 it's a requirement for my development environment

I am using IntelliJ IDEA and I have JDK 8 and JDK 11 on one machine.
I can define in the project settings, which JDK should be used for the project.

I am using JDK 11 now as a standard but language level and byte code level are still defined as 8.

summary: - [1.1.4] macOS 10.14: IDE does not start up --- tested with Java 11 ---
- works
+ [1.1.4] macOS 10.14: IDE does not start up --- tested with Java 11 and
+ Java 8 --- works
Teresa (wiris) wrote :

Thank you Raiman!

I have finally managed to make Sikuli IDE work... I just deleted the *.jars and downloaded them again in another location... I suppose there was something rotten in my machine...

Thanks again!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions