Activity log for bug #1791599

Date Who What changed Old value New value Message
2018-09-10 09:30:43 RaiMan bug added bug
2018-09-10 09:30:55 RaiMan sikuli: status New Fix Committed
2018-09-10 09:30:59 RaiMan sikuli: importance Undecided High
2018-09-10 09:31:02 RaiMan sikuli: assignee RaiMan (raimund-hocke)
2018-09-10 09:31:06 RaiMan sikuli: milestone 1.1.4
2018-09-10 09:31:42 RaiMan summary [1.1.4] IDE: App.open not working (only when run from commandline) [1.1.4] IDE: App.open not working (only when run from commandline) --- workaround
2018-09-10 09:33:16 RaiMan description I am using Java 8 and SikuliX 1.1.4 IDE. I have a test script that uses App.open to run a Windows batch script that launches a program. If I run the test script from the Windows command line it launches the tool from the batch script, however, if I run the same test script from the IDE, the tool is not launching. This works fine in both the IDE and the command line when using SikuliX 1.1.0 *************** workaround edit and save script in IDE, but run from commandline in parallel ;-) ---------------------------------- I am using Java 8 and SikuliX 1.1.4 IDE. I have a test script that uses App.open to run a Windows batch script that launches a program. If I run the test script from the Windows command line it launches the tool from the batch script, however, if I run the same test script from the IDE, the tool is not launching. This works fine in both the IDE and the command line when using SikuliX 1.1.0
2018-09-10 09:34:03 RaiMan summary [1.1.4] IDE: App.open not working (only when run from commandline) --- workaround [1.1.4] IDE: App.open("cmd ...") not working (only when run from commandline) --- workaround
2018-09-10 09:36:29 RaiMan description *************** workaround edit and save script in IDE, but run from commandline in parallel ;-) ---------------------------------- I am using Java 8 and SikuliX 1.1.4 IDE. I have a test script that uses App.open to run a Windows batch script that launches a program. If I run the test script from the Windows command line it launches the tool from the batch script, however, if I run the same test script from the IDE, the tool is not launching. This works fine in both the IDE and the command line when using SikuliX 1.1.0 --- problem … only exists when trying to open a command prompt window, to run something there. *************** workaround edit and save script in IDE, but run from commandline in parallel ;-) … or make some experiments with Python subprocess.Popen() ---------------------------------- I am using Java 8 and SikuliX 1.1.4 IDE. I have a test script that uses App.open to run a Windows batch script that launches a program. If I run the test script from the Windows command line it launches the tool from the batch script, however, if I run the same test script from the IDE, the tool is not launching. This works fine in both the IDE and the command line when using SikuliX 1.1.0
2018-09-10 09:37:41 RaiMan description --- problem … only exists when trying to open a command prompt window, to run something there. *************** workaround edit and save script in IDE, but run from commandline in parallel ;-) … or make some experiments with Python subprocess.Popen() ---------------------------------- I am using Java 8 and SikuliX 1.1.4 IDE. I have a test script that uses App.open to run a Windows batch script that launches a program. If I run the test script from the Windows command line it launches the tool from the batch script, however, if I run the same test script from the IDE, the tool is not launching. This works fine in both the IDE and the command line when using SikuliX 1.1.0 --- problem … only exists when trying to open a command prompt window, to run something there. For normal GUI applications (browsers, editors, …) it seems to work. *************** workaround edit and save script in IDE, but run from commandline in parallel ;-) … or make some experiments with Python subprocess.Popen() ---------------------------------- I am using Java 8 and SikuliX 1.1.4 IDE. I have a test script that uses App.open to run a Windows batch script that launches a program. If I run the test script from the Windows command line it launches the tool from the batch script, however, if I run the same test script from the IDE, the tool is not launching. This works fine in both the IDE and the command line when using SikuliX 1.1.0
2018-09-17 07:42:26 RaiMan sikuli: importance High Critical
2018-09-17 07:42:46 RaiMan summary [1.1.4] IDE: App.open("cmd ...") not working (only when run from commandline) --- workaround [1.1.4] IDE: App.open("cmd ...") not working (only when run from commandline) --- fixed 2018-09-16
2018-11-07 16:04:53 Rainer bug added subscriber Rainer