[1.1.1] macOS 10.12.3: dragDrop not working --- seems to be a Java related problem

Bug #1664969 reported by Bartel Eerdekens on 2017-02-15
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Sikuli
Medium
RaiMan

Bug Description

Hello,

While using SikuliX IDE 1.1.1 (Also tried 1.1.0, same behaviour), on OSX 10.12.3 (Sierra) the drag and drop functionality does not seem to work as expected.

In my simplified application I have a left-side drawer (mobile style) which can be pulled-out and pushed-in.

Somehow the pulling-out function works as expected, but the pushing-in does not work.
On Windows (running in VirtualBox) with the same (Qt Quick 2.0) code-base and same Sikuli test code, all is functioning well (While I cannot see the mouse cursor moving, but I think this is due to the usage of VirtualBox).

I tried to do the drag and drop manually with mouseDown(Button.Left), mouseMove(...) and mouseUp() but even that does not resolve the issue on OSX. Also tried to alter the timing Settings (DelayBeforeDrag, DelayBeforeDrop, DelayBeforeMouseDown) as putting manual delays (sleep). No effect however.

I tried debugging with a mouse-locator (show click actions), and everything seems fine, being: following the sequence: press/hold - move - release...

What I also noticed is that the animation of my drawer popping in/out is not showing while running a SikuliX test.

Attached you can find the windows application, as the mac application as the used (minimised) test script.

Bartel Eerdekens (letrab) wrote :
Bartel Eerdekens (letrab) wrote :
Bartel Eerdekens (letrab) wrote :
  • Mac app Edit (22.1 MiB, application/x-apple-diskimage)
description: updated
description: updated
RaiMan (raimund-hocke) on 2017-02-15
summary: - Mac OS X Sierra 10.12.3 dragDrop not working
+ [1.1.1] macOS 10.12.3: dragDrop not working
Changed in sikuli:
status: New → In Progress
importance: Undecided → High
assignee: nobody → RaiMan (raimund-hocke)
milestone: none → 1.1.1

I just played a little on my macOS 10.12.3:
I could reproduce this odd behavior, but do not have any idea currently.

This sequence e.g. works:
win = App.focusedWindow()
win.highlight(2)
p1 = Location(win.x + 10, win.y + win.h/2)
p2 = p1.offset(400, 0)

mouseDown(Button.LEFT)
mouseMove(p2)
wait(1)
mouseMove(p1)
mouseUp()

this opens and closes the drawer.
But if you do a mouseUp() in between, the next mouseDown() seems not to be recognized.

I will make a test directly with Java AWT Robot.

RaiMan (raimund-hocke) wrote :

Ok, also reproduced with Java Robot:
with an opened drawer, the mouse down is not recognized by the widget.

conclusion: another problem in the bermuda triangle of Java, macOS and GUI programming.

... so there is no solution for that in the moment - sorry.

Changed in sikuli:
status: In Progress → Confirmed
importance: High → Medium
summary: - [1.1.1] macOS 10.12.3: dragDrop not working
+ [1.1.1] macOS 10.12.3: dragDrop not working --- seems to be a Java
+ related problem
Bartel Eerdekens (letrab) wrote :

Thank you for your quick investigation!

Hopefully, with upcoming 2.0, the issue will be lost somewhere in that bermuda triangle ;-).

RaiMan (raimund-hocke) wrote :

Good news (though does not help you currently):
yesterday I implemented the drag/drop feature in version 2:
and oh wonder: it works with your widget :-)

... but I am not aware about the differences yet - I will check the next days, if I get the time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers