[1.1.0] addImagePath NoMethodError --- workaround: use ImagePath.add instead

Bug #1473631 reported by RaiMan on 2015-07-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Sikuli
High
RaiMan

Bug Description

I would like to use the addImagePath in a script.
When I run it I get the following error:
[error] script [ repository ] stopped with error in line 10
[error] NoMethodError ( (NoMethodError) undefined method `addImagePath' for main:Object )
[error] --- Traceback --- error source first line: class ( method ) file 10: RUBY ( (root) ) C:/sikuliscripts/FTAS/repository.sikuli [error] --- Traceback --- end --------------

NoMethodError: undefined method `addImagePath' for main:Object (root) at C:/sikuliscripts/FTAS/repository.sikuli:10

Code looks like:
#add path to the project
addImagePath('..//generic.sikuli')

I use Sikuli 1.1.0.
In the IDE I do see that the addImagePath turns green, so, I do expect it to be valid.

Just for checking, I also tried the methode getImagePath, but here I get the same error.

RaiMan (raimund-hocke) on 2015-07-11
Changed in sikuli:
status: New → In Progress
importance: Undecided → High
assignee: nobody → RaiMan (raimund-hocke)
milestone: none → 1.1.0
summary: - [1.1.0] addImagePath NoMethodError --- workaround: use
- ImagePath.addImagepath instead
+ [1.1.0] addImagePath NoMethodError --- workaround: use ImagePath.add
+ instead
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions