[1.1.0] OSX 10.7: Can't use App.open, openApp, App.focus running script from IDE started as app --- workarounds 2015-06-19+

Bug #1465945 reported by RaiMan on 2015-06-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Sikuli
High
RaiMan

Bug Description

************ workarounds

--- run your script from command line (Terminal)

or

--- start the IDE as "non-application"

After having moved the SikuliX.app to /Applications use the provided command scripts

- doubleclick runsikulix
- in a Terminal use runsikulix (if you want to provide parameters)
- in a Terminal use /Applications/SikuliX.app/run (equivalent to runsikulix)

running scripts from the so started IDE behave the same as when run from command line.

----------------------------------------------------

Updated to latest build of 1.1 today, and my scripts that previously worked fine on 1.0 have now stopped working..

Env:
Mac 10.7
Sikuli IDE 1.1 2015-06-04

I can't open any app with Sikuli, I have tried the following:
# Open the app if its not already open
openApp("Safari.app")
wait(2)
App.open("Safari.app")
wait(2)
App.focus("Safari.app")

It just blinks in the Dock, and then nothing happens (app not docked)

output:
[log] App.open [-1:Safari]
[log] App.open [-1:Safari]
[log] App.focus: [-1:Safari]

RaiMan (raimund-hocke) wrote :

details see related question

Changed in sikuli:
status: New → In Progress
importance: Undecided → High
assignee: nobody → RaiMan (raimund-hocke)
milestone: none → 1.1.0
RaiMan (raimund-hocke) on 2015-06-19
description: updated
summary: [1.1.0] OSX 10.7: Can't use App.open, openApp, App.focus running script
- from IDE started as app --- workaround: run script from Terminal
+ from IDE started as app --- workarounds 2015-06-19+
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers