[1.1.x] IDE displaying image filename instead of images in some situations (e.g. after import problems)

Bug #1454440 reported by Erich Fiederer on 2015-05-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Sikuli
Undecided
RaiMan

Bug Description

******* workaround: restart IDE

------- IDE problems will not be fixed any more (May 2017)
developement for the IDE is stopped with version 1.1.1
Version 2 will have a different approach
***********************************************

using 1.1 IDE on 2015-04-28 nightly with OSX 10.10

Sometimes when I open a sikuli file in the IDE, the images do not display, only the file name.

This occasionally fixes itself when I close and reopen the file.

Screenshot: http://imgur.com/W2L54vH

RaiMan (raimund-hocke) wrote :

please try again with the latest build.

Erich Fiederer (erichfiederer) wrote :

Hi RaiMan,

Looks like this is still an issue as of 2015-05-13 nightly build.

Screenshot: http://imgur.com/in0azVH

RaiMan (raimund-hocke) wrote :

ok, I will try to find out, what this might be.

... the blanks in the filename????

Erich Fiederer (erichfiederer) wrote :

It could be, but it happens with images without any spaces as well.

Worthy of note, it generally happens after one of my files failed to import in my main sikuli script and I open up the file that failed to see what went wrong.

RaiMan (raimund-hocke) wrote :

Thanks for this additional hint.

Makes some sense to be the reason for this weird behaviour.

Changed in sikuli:
status: New → In Progress
importance: Undecided → High
assignee: nobody → RaiMan (raimund-hocke)
milestone: none → 1.1.0
summary: - IDE displaying text instead of images
+ [1.1.0] IDE displaying text instead of images

This happens to me almost every time I open a new file within the IDE. If I close and reopen the IDE, the images display. Has this bug ever been fixed? I'm using SikulixIDE 1.1.1. I installed it less than a month ago, but this bug is about 2 years old.

RaiMan (raimund-hocke) on 2017-05-09
Changed in sikuli:
milestone: 1.1.0 → none
status: In Progress → Won't Fix
importance: High → Undecided
RaiMan (raimund-hocke) on 2017-05-09
description: updated
summary: - [1.1.0] IDE displaying text instead of images
+ [1.1.x] IDE displaying text instead of images
summary: - [1.1.x] IDE displaying text instead of images
+ [1.1.x] IDE displaying text instead of images in some situations (e.g.
+ after import problems)
summary: - [1.1.x] IDE displaying text instead of images in some situations (e.g.
- after import problems)
+ [1.1.x] IDE displaying image filename instead of images in some
+ situations (e.g. after import problems)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers