[ALL VERSIONS] IDE does not start up on MAC OSX 10.10 Yosemite --- 1.1.0 works (RC3 + 1.0.1 do not)

Bug #1362011 reported by RaiMan on 2014-08-27
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Sikuli
Critical
RaiMan

Bug Description

A related typical Mac bug 1385595 (open scripts on OS X not possible)

------ 1.1.0 works (temp fix)
switched of the search feature temporarily, that caused the crash
nightly build available after August 28th
---------------------------

RC3 and 1.0.1: will never be supported on OS X 10.10

1.0.1: running scripts from command line should work (sikuli-script.jar) and usage in Java (sikuli-java.jar)

--------------------------------------------------
I was trying to run Sikuli 1.0.1 on Mac OSX 10.10. But it doesn't even able to open it & immediately turns into not responding mode.
I have tried it with sikuli 1.1 beta version but this also not able to open sikuli. Please let me know if anyone has resolved this issue.

RaiMan (raimund-hocke) on 2014-08-27
Changed in sikuli:
status: New → In Progress
importance: Undecided → High
assignee: nobody → RaiMan (raimund-hocke)
milestone: none → 1.1.0
RaiMan (raimund-hocke) on 2014-08-27
description: updated
summary: - [ALL VERSIONS] IDE does not start up on MAC OSX 10.10 Yosemite
+ [ALL VERSIONS] IDE does not start up on MAC OSX 10.10 Yosemite --- temp
+ fix for 1.1.0
description: updated
RaiMan (raimund-hocke) on 2014-08-28
Changed in sikuli:
status: In Progress → Fix Committed
RaiMan (raimund-hocke) on 2014-10-24
Changed in sikuli:
importance: High → Critical
description: updated
summary: - [ALL VERSIONS] IDE does not start up on MAC OSX 10.10 Yosemite --- temp
- fix for 1.1.0
+ [ALL VERSIONS] IDE does not start up on MAC OSX 10.10 Yosemite --- 1.1.0
+ works (RC3 + 1.0.1 do not)
Christopher Green (chriszold) wrote :
Download full text (3.4 KiB)

Hi. Just wanted to contribute as (primarily) a Mac user. I had (these known) troubles with Sikuli with Yosemite and the last version of the OS, but recently downloaded 1.1.0 of Sikuli and have it working, but I'd like to make clear a few things that I can see leading people to give up on the installation (if they get flustered or run into other problems that don't seem to be covered clearly on this site or find the site difficult to navigate [come on, it's possible :-) ] ).

For those of you wanting to install this on OSX 10.10 (and possibly 10.9):

I now have, on OSX 10.10.1 a working version of Sikuli with Java 8 update 25 and Sikuli 1.1.0 (using the "sikulixsetup-1.1.0" link).

Pay attention to the "install into empty folder" instruction. The jar setup file will install libraries into a separate (libs) folder and a "runsikulix" binary (as well as an installation log), and it will be easier if the Sikuli installer (setup) does this in its own empty folder.

You should be able to double-click the sikulix.jar file that is installed, and this will launch the app.

This is a Java application, not a standard OSX app, so it does not respond to OSX app things, like drag and drop. Unless you set up a script application (or some such creation) to accept file dropping, opening files will have to be done from within the app via the File menu. But ...

I found that if I created a script project and saved it, and closed the document in Sikuli, I was unable to re-open it because the .sikuli folder (containing the png images, .py script, html file) was not recognized as a bundle (which is essentially a folder wearing a file disguise, as it were, for those of you who didn't know). This problem has been mentioned somewhere on this site, I think.

One way to deal with this (until the official working OSX app version is released) is to download a free utility called "kilometre" (avl from macupdate.com) and use this utility to open the folder _containing_ one of the .sikuli "folders". Those sikuli folders will be listed in kilometre, and you can select one (in Kilometre) and hit command-i to bring up the window that allows you to turn on the "has Bundle" checkbox. This turns the folder into the bundle (package) it is supposed to be, and now can be opened correctly from Sikuli (but -- like the mentioned drag/drop issue above, you also won't be able to double click one of these .sikuli files (bundles) to open them, either.

There are some major problems with capturing images in Sikuli, for example to create a wait() command. This is pretty bad. If I want to capture the menu, there is just _no way to do it_ with the Sikuli interface. The best way is to:

a) type in (for example) "wait()", place the cursor between the parentheses,

b) capture your OWN image using command-shift-4 (capture region) or command-shift-option-4 (capture region to clipboard), save it as a png image,

c) then use Sikuli's Insert image feature to place that image between the parens.

I admit that I have a script that I use to save png images from the clipboard into sikuli bundles.

I hope the developers fix the problems with capturing on OSX. It was awkward with previous versions of the ...

Read more...

Christopher Green (chriszold) wrote :

I meant to add this Kilometre image to the earlier comment.

RaiMan (raimund-hocke) on 2014-12-09
description: updated
RaiMan (raimund-hocke) wrote :

@Christopher
Thanks for the detailed description.

some comments:

--- There are some major problems with capturing images in Sikuli, for example to create a wait() command
... please give more detailed information about the problem you have

--- but it is particularly problematic now, esp. when needing the main menu bar and menu items.
main menu bar: just start the capture directly below the bar and drag towards top
menu items: should always work with the "Quick Capture Hotkey" (bring app to front, navigate to wanted state and use hotkey, the captured image will go to the IDE window)

--- the open bundle problem and a workaround is described in bug 1385595
... i have revised the workaround descriptions and added bug links

again thanks for your contribution.

Christopher Green (chriszold) wrote :

Hi RaiMan, thanks for the response.
I should've specified that the problems stem from the capture problem -- which as you mentioned, can be alleviated by using the hotkey. I just think it is unfortunate that the default behavior of the interface is autocapture, which doesn't work with menu stuff and even if it weren't on as a default, it seems like it (I'm sure you'd agree) should work. And I'm pretty sure it did (?) in previous OS versions (it must have; I don't remember these issues when I first started messing around with Sikuli).
The workaround you mentioned was something I was guessing word work, but I already had Kilometre (and the developer tools, which also give the power to set directory bundle bits of course) and don't really want other versions of an app around if I can help it.
I'm assuming you are familiar with the autocapture problem and don't need me to explain it in detail? I'd be happy to upload a movie if you want.
Thanks again

-cg

RaiMan (raimund-hocke) wrote :

Both situations (auto capture as default and cannot-capture-menu-entries) are different things.

The first belongs to the usage, that you are working in the IDE and either use a CommandList entry with auto capture on or one of the capture buttons (inline with auto capture off or the tool bar button). In this case it will not be possible with standard OS X applications to capture menu entries, since the last click will be in the IDE, which switches focus and closes any open menu.

So as long as I know Sikuli (since 2009), you always had to use the capture hotkey, to have a chance to get menu images with the means of the IDE (which is the second area).

The alternate way (using the OS X capture feature and insert the image) always worked in the past.

BTW: the command list is only for absolute beginners and something like a poor man's auto completion. People writing more complex scripts will usually assign images to variables and use one of the new IDE features (compact image buttons and pure text editing) or even work with a mature IDE like Eclipse.

Nevertheless: the capture feature will be revised with version 1.2 anyway and if I succeed in implementing some auto completion, then this will be the end of the command list (which already now can be switched off completely)

NoBugs! (luke32j) wrote :

It's actually not fixed on Mac OS 10.10.1. I get the "you need to install a JDK" alert when running ./runsikulix with Sikuli 1.1.0 preview release. I had already installed Java (twice) and restarted (if that makes a difference), when 1.0 asked to install it.

Changed in sikuli:
status: Fix Committed → Confirmed
RaiMan (raimund-hocke) on 2014-12-31
Changed in sikuli:
status: Confirmed → Fix Committed
Michael P (mpacker99) wrote :

It really sucks that this will not install properly on a mac. I downloaded newest version of java and 1.01 (the "stable" version, yeah)

It just sits there at the "please wait".. spent a couple hours trying things...

it looks like it has potential but the bad mac install has left a sour taste. guess it's time to buy software that does what i want.

Christopher Green (chriszold) wrote :

I agree Michael. I have my workaround version working great, but a proper OSX installer is way overdue.

RaiMan (raimund-hocke) wrote :

@Christopher
Thanks for the more polite comment.

It is not the installer, that makes the problem on OS X 10.10.
The installer works fine.

The IDE does not start up caused by the mentioned problem with the search option in the main window (apple changed the search feature as you might know and it seems at least not be backwards compatible for the use with Java)

... and as mentioned in the top post:
- IDE 1.0.1 will never run on OS X 10.10
- version 1.1.0 works, so you might give it a try

One more thing:
With a new system version and a new software having problems, one should latest after the 2nd or 3rd trial look into the net.
When asking google "Sikuli OS X 10" you get a link to this bug as the 3rd entry.
I am sorry for any inconvenience with SikuliX, but I am not responsible for someone spending hours simply repeating the same not working approach.

Christopher Green (chriszold) wrote :
Download full text (3.5 KiB)

Hi RaiMan.
You're quite right; The nightly build installer now works great and results in a standard app. To be clear, I'm on OSX Yosemite 10.10.2 at this point, and Java Version 8, update 40.

One of the problems here is that when someone (like Michael) sees "stable version' on the website, it is fairly reasonable to expect them to make assumptions about that link. Not having a clear file to install a working version on OSX in a fairly standard way (I realize though, that at this point there IS a standard installed app now, see below) is likely to make people give up on using this software. It's almost a given that most visitors to this site would not bother to complain about it. The kind of complaint that gets through will be like Michael's which, though less "polite", is totally expected, in my view.

Having instructions like this:

"2. How do I download SikuliX
We are still on the Nightly Build page with version 1.1.0 pre-final:
If you are sure: Using the following link will directly start the download of sikulixsetup-1.1.0.jar."

Is confusing. "We are still on the Nightly Build page" doesn't tell the visitor anything about what version works with what. Especially if "stable version" is usually assumed to be the safe working version. "If you are sure" is also totally confusing. Sure about what? It's just not working, from a reasonable user interface/browsing perspective.

I could get into the minutia about why the site and its OSX versions are confusing or misleading, but it should suffice to say that there is a lack of clarity here. And simplicity. Here's the ideal: One page of instructions. Mavericks+? LINK->DOWNLOAD->INSTALL. DONE.

Now, just to be sure I understood everything in its latest form, I zipped everything I had for backup (which still used the .jar, not the .app, to launch Sikuli), deleted those originals, and reinstalled from the "sikulixsetup-1.1.0.jar" file. Everything works great, so I deleted my back up zips (after grabbing my existing scripts and putting them in my new Sikuli folder) and have the new app working. And I don't have to bother with the bundle flag stuff with the .sikuli files (because the app takes care of that now, as it should, as you mentioned).

FOR ANYONE WHO IS CONFUSED ABOUT WHAT TO INSTALL, HERE IS WHAT YOU DO (there are a few personal preferences here, but I think this is the best process):
==============================================
If you have OSX Mavericks or later, go to the http://nightly.sikuli.de/ page (the nightly builds page), ignore everything but the part that reads:

"The only file needed to download:
sikulixsetup-1.1.0 (store and run in an empty folder)"

... and download that sikulixsetup file.

Put this in its own folder, call the folder "Sikuli".

Run the setup file. Choose option 1, add the jruby option. Install and wait for downloading and installing to do their thing.

You should get the "Hallo from Sikulix.texstSetup. Python Scripting SikuliX seems to be working!" message (maybe two of these).

You can now move the Sikuli folder containing the app, the "Downloads" folder and the setup file to the standard /Applications/ folder. You can delete both the "Downloads" folder i...

Read more...

RaiMan (raimund-hocke) wrote :

@Christopher
I really appreciate your clear and reasonable comment. Very helpful if someone not only companies about having problems, but clearly says, what is confusing and what worked.

I will pick up your suggestions and make things clearer.

Thanks again.

David (nghiem-ngo) wrote :

Omg I love you Christopher! Thank you! I have been stuck with this for almost a year and I thought I would never be able to use it. Thank you so much.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments