[1.0.1] red croshair interferes with menus --- Settings.ShowActions not reset

Bug #1328424 reported by Samuel John King on 2014-06-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Sikuli
High
RaiMan

Bug Description

I assume my sikuli has updated as I have new menus. during click events a red croshair appears. This croshair interferes with buttons that have a sub menu. ie. File - Save. When the crosshair appeasres the menu disappears. This same script worked in a earlier version. The check for updates menu was also unticked.

1. The current version is 1.0.1, but I think the last one was as well.
2. 64 Windows 8 or 8.1
3. click(Pattern(File (image))
     click(Pattern(Save (image))
     (specifically the project 64 emulator)
4. It did not happen before and now it does, I assume update but not version change.
    Before it was the first time I ran sikuli and the croshair was not there. After PC restart it is.

Samuel John King (samjohnking) wrote :

Interesting.
The crosshair has now fucked off again ( The IDE reloaded itself on the next run) and all is fine :)

RaiMan (raimund-hocke) wrote :

The crosshair comes up, when running a script in slow motion (yellow run button) and is currently not switched off, until the IDE is reloaded.

To switch it off/on during a script run:
setShowActions(True) # on
setShowActions(False) # off

Changed in sikuli:
status: New → Confirmed
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → RaiMan (raimund-hocke)
milestone: none → 1.1.0
summary: - red croshair interferes with menus
+ [1.0.1] red croshair interferes with menus --- Settings.ShowActions not
+ reset
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers