signon-ui fails to build because libicu not available during build (Qt 5.2)

Bug #1287177 reported by Timo Jyrinki on 2014-03-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Online Accounts: Sign-on UI
High
Timo Jyrinki

Related branches

Alberto Mardegan (mardy) wrote :

Maybe the dependency is brought in by QtWebKit 1, which probably is not being used by other packages which build fine.
I think that adding the package to the build-dependencies will fix the error.

Timo Jyrinki (timo-jyrinki) wrote :

Seems to work (amd64 so far):

https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2/+sourcepub/3952779/+listing-archive-extra

Please approve the branch. I added it already to http://pad.ubuntu.com/qt52-dependencies so it can land together with Qt 5.2 via CI Train.

Le 03/03/2014 16:12, Alberto Mardegan a écrit :
> Maybe the dependency is brought in by QtWebKit 1, which probably is not being used by other packages which build fine.
> I think that adding the package to the build-dependencies will fix the error.
We recently had to fix an ICU runtime issue in Cordova, which was caused
by an uncontrolled import of the latest ICU version from Debian.

I think the plan defined was to stay with ICU while we were on Qt 5.0.2
but switch to using Qt functions with 5.2, and thus drop using ICU.

Can that plan apply to signon-ui as well?

David

Alberto Mardegan (mardy) wrote :

signon-ui is not calling any ICU functions. I suspect that the dependency is brought in by WebKit1.

Changed in signon-ui:
status: New → In Progress
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in signon-ui:
status: In Progress → Fix Committed
Changed in signon-ui:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers