Cannot log in to Google apps domain + Ubuntu SSO

Bug #1171853 reported by David Planella on 2013-04-23
264
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Online Accounts: Sign-on UI
Critical
Alberto Mardegan
signon-ui (Ubuntu)
Undecided
Unassigned
Raring
High
Unassigned

Bug Description

I'm trying to log in to my Google apps account through the Online Accounts dialog and so far I've been unsuccessful.

From the online accounts dialog, after the Google login page, I'm then taken to the Ubuntu SSO page, but when I enter my SSO user name and password, I get a blank screen with an error message that doesn't give me any pointers as to what's happened (see attached screenshot).

I'm also attaching the output generated by invoking signon-ui from the command line with SSOUI_LOGGING_LEVEL=2

Additional information for the SRU request:

[Impact] Makes it impossible to create Google apps accounts linked to Ubuntu SSO (and possibly others).

[Test Case] Open Online Accounts, click on "Add account", choose "Google", then enter your e-mail address (leave the password field empty), and press "Sign in". Follow the instructions, but if the bug is not fixed you'll soon be presented with the error message from comment #2. If the bug is fixed, the account creation should complete successfully.

[Regression Potential] The code paths touched by this patch are only hit when a web page fails to load; we simply delay reporting the error by 3 seconds, and cancel the error condition if in the meantime the WebView has shown some signs of activity. So, this patch should not affect the successful creation of other accounts, but just add a small delay to the ones failing because of network errors.

Related branches

David Planella (dpm) wrote :
David Planella (dpm) wrote :
David Planella (dpm) on 2013-04-23
information type: Private Security → Public Security
Alberto Mardegan (mardy) on 2013-04-23
Changed in signon-ui:
assignee: nobody → Alberto Mardegan (mardy)
status: New → In Progress
importance: Undecided → Critical
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:signon-ui at revision 87, scheduled for release in signon-ui, milestone 0.12

Changed in signon-ui:
status: In Progress → Fix Committed
David Planella (dpm) on 2013-04-23
description: updated
Alberto Mardegan (mardy) on 2013-04-24
description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:signon-ui at revision 88, scheduled for release in signon-ui, milestone 0.12

Changed in signon-ui (Ubuntu Raring):
importance: Undecided → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-ui - 0.14-0ubuntu2

---------------
signon-ui (0.14-0ubuntu2) saucy; urgency=low

  [ Alberto Mardegan ]
  * Fix a crash potentially happening when the XEmbed container reused the
    same X window ID from a previous one. (LP: #1158969)
  * Fixed Cannot log in to Google apps domain + Ubuntu SSO (LP: #1171853)
 -- Ken VanDine <email address hidden> Wed, 29 May 2013 10:37:43 -0400

Changed in signon-ui (Ubuntu):
status: New → Fix Released
Tuomas Lähteenmäki (lahtis) wrote :

Same errors with facebook account. 5 minute intervals combination browser request. using ubuntu 12.10 version.

Clint Byrum (clint-fewbar) wrote :

Hi, the SRU uploaded is missing information which identifies which fix is which patch. They are both muddled together and it is basically impossible to discern what is what. Please add information to the changelog explaining how it was fixed, or comment the changes, so that we can tell which change belongs to which bug.

In addition, bug #1158969 is missing the required SRU information. It has been waiting for an answer for over a month, so I'm rejecting the upload.

Alberto Mardegan (mardy) wrote :

Sorry Clint, I completely missed the comment to bug #1158969 and I've now added the SRU information.

About this bug, the actual patch is http://bazaar.launchpad.net/~online-accounts/signon-ui/trunk/revision/87

Changed in signon-ui (Ubuntu Raring):
status: Confirmed → Won't Fix
David Barth (dbarth) on 2014-09-29
Changed in signon-ui:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers

Bug attachments