[OnlineAccounts] Ship and enable SASL authentication plugin

Bug #1519330 reported by Alberto Mardegan on 2015-11-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
Ubuntu Online Accounts API
High
Alberto Mardegan
signon-plugin-sasl
High
Alberto Mardegan
webapps-sprint
High
Alberto Mardegan

Bug Description

E-mail, XMPP and other services often uses SASL as authentication method. In the Online Accounts project there is an authentication plugin for SASL, from the old Nokia times (2011) and hasn't been maintained since.

The first step in order to bring this plugin to Ubuntu is building the plugin and packaging it.

Then, it appears that there are some changes to be done either in the plugin or in the OA APIs, due to the dynamic nature of SASL (the list of mechanisms is known only at runtime, because it's coming from the remote server). Nor the older QML API from online-accounts-module nor the new v2 API from online-accounts-api support changing the mechanism at runtime.
To me, it seems that the best way to solve this is actually to modify the SASL plugin, and create an input parameter in which the client can specify the initial list of mechanisms.

The third thing to do is create a simple QML application which QA can use to test the plugin and catch possible regressions.

Related branches

Alberto Mardegan (mardy) on 2015-12-01
Changed in signon-plugin-sasl:
status: Confirmed → In Progress
Changed in webapps-sprint:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Mardegan (mardy)
milestone: none → sprint-17
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → David Barth (dbarth)
milestone: none → ww02-2016
David Barth (dbarth) on 2015-12-08
Changed in webapps-sprint:
status: In Progress → Fix Committed
Changed in signon-plugin-sasl:
status: In Progress → Fix Committed
Alberto Mardegan (mardy) on 2016-01-12
Changed in online-accounts-api:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Mardegan (mardy)
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2016-04-26
Changed in online-accounts-api:
status: In Progress → Fix Released
Changed in signon-plugin-sasl:
status: Fix Committed → Fix Released
Changed in webapps-sprint:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers