Dropbox upload should urlencode the resuting link

Bug #965589 reported by Zach McCullough
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shutter
Fix Released
Low
Mario Kemper (Romario)

Bug Description

When you upload to dropbox, the resulting link can potentially have spaces in it. This makes pasting a link an inconvenience as you either have to paste the link into a browser to urlencode it, or you have to manually add the %20s.

Changed in shutter:
assignee: nobody → Mario Kemper (Romario) (mario-kemper)
importance: Undecided → Low
milestone: none → 0.88.3
status: New → Confirmed
Revision history for this message
Vadim Peretokin (vperetokin) wrote : Re: [Bug 965589] [NEW] Dropbox upload should urlencode the resuting link

As a note, it'd be nicer to use + instead of %20, which is also valid.

Revision history for this message
Mario Kemper (Romario) (mario-kemper) wrote :

@Vadim: Valid point but I am using http://search.cpan.org/~gaas/URI-1.60/URI/Escape.pm (a very common module). It will be percent-encoded.

Changed in shutter:
status: Confirmed → Fix Committed
Revision history for this message
Zach McCullough (nosrepa) wrote : Re: [Bug 965589] Re: Dropbox upload should urlencode the resuting link

Thank you!

On Tue, Mar 27, 2012 at 6:23 AM, Mario Kemper (Romario) <
<email address hidden>> wrote:

> @Vadim: Valid point but I am using
> http://search.cpan.org/~gaas/URI-1.60/URI/Escape.pm (a very common
> module). It will be percent-encoded.
>
> ** Changed in: shutter
> Status: Confirmed => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/965589
>
> Title:
> Dropbox upload should urlencode the resuting link
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/shutter/+bug/965589/+subscriptions
>

--
<email address hidden> | moc.liamg@aperson

Revision history for this message
Vadim Peretokin (vperetokin) wrote :

Could make an exception to replace after encoding?
On Mar 28, 2012 4:55 AM, "Zach McCullough" <email address hidden> wrote:

> Thank you!
>
> On Tue, Mar 27, 2012 at 6:23 AM, Mario Kemper (Romario) <
> <email address hidden>> wrote:
>
> > @Vadim: Valid point but I am using
> > http://search.cpan.org/~gaas/URI-1.60/URI/Escape.pm (a very common
> > module). It will be percent-encoded.
> >
> > ** Changed in: shutter
> > Status: Confirmed => Fix Committed
> >
> > --
> > You received this bug notification because you are subscribed to the bug
> > report.
> > https://bugs.launchpad.net/bugs/965589
> >
> > Title:
> > Dropbox upload should urlencode the resuting link
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/shutter/+bug/965589/+subscriptions
> >
>
>
> --
> <email address hidden> | moc.liamg@aperson
>
> --
> You received this bug notification because you are a member of Shutter
> Team, which is subscribed to Shutter.
> https://bugs.launchpad.net/bugs/965589
>
> Title:
> Dropbox upload should urlencode the resuting link
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/shutter/+bug/965589/+subscriptions
>

Changed in shutter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers