Tab closing crashes in some circumstances

Bug #708753 reported by tuxmaniack on 2011-01-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shutter
Low
Mario Kemper (Romario)

Bug Description

First crash when image is removed from disk.
Second when image is modified by another program.

Shutter 0.86.4, Rev.906
For more info see attached videos.

tuxmaniack (tuxmaniack) wrote :
tuxmaniack (tuxmaniack) wrote :

Could you please try to reproduce this with the latest version of Shutter? Thanks for your help.

tuxmaniack (tuxmaniack) wrote :

Shutter 0.87 Rev.1048

First crash when image is removed from disk still occurs in about 99% when re-save warnings on, but in this version I can disable them.
Second bug when image is modified by another program looks fixed.

This is happening because you close the dialog without choosing one of the options (save or discard). This leads to the fact that the tab is still there. Anyway, this is a bug, thanks for reporting.

Changed in shutter:
assignee: nobody → Mario Kemper (Romario) (mario-kemper)
importance: Undecided → Low
milestone: none → 0.87.1
status: New → Confirmed
Changed in shutter:
status: Confirmed → Fix Committed
Changed in shutter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers