Shutter - Screenshot Tool

Shutter failed to take screenshot on seamless mode of virtualbox by indicating "Keyboard could not be grabbed"

Reported by Justin on 2011-01-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shutter
Low
Mario Kemper (Romario)

Bug Description

I am running Windows XP in Virtualbox on host Ubuntu 10.04. For convenience I normally set my virtual XP into seamless mode, a new function Virtualbox provided lately..

However, Shutter installed on host fails to take screenshot when I try to take screenshot on windows in my virtual XP. It gave an error msg " Keyboard could not be grabbed" ..

If I set Virtual XP back to normal mode, Shutter works perfectly fine..

Any idea on this problem please?

Confirmed. It is because the non-visible VirtualBox window grabs keyboard focus immediately when the Shutter window hides. Are you able to activate the selection mode via Shutter's tray icon?

Changed in shutter:
assignee: nobody → Mario Kemper (Romario) (mario-kemper)
importance: Undecided → Low
milestone: none → 0.87.1
status: New → Confirmed
Justin (justin-wzy) wrote :

I am afraid I can not activate the selection mode from the tray icon either.. same error

Changed in shutter:
milestone: 0.87.1 → 0.87.2
Changed in shutter:
status: Confirmed → In Progress
milestone: 0.87.2 → 0.87.1
Changed in shutter:
status: In Progress → Fix Committed
Changed in shutter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers