[Selection] Enter and Escape keys don't work any more

Bug #705094 reported by Photon on 2011-01-19
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Shutter
Medium
Mario Kemper (Romario)

Bug Description

More detailed description here: http://forum.ubuntuusers.de/topic/shutter-screenshot-programm-eingabetaste-funkt/

Reproducible with Arch Linux and Ubuntu Maverick, latest bzr build (rev. 1029) of Shutter.

It does work on maverick again, but it still does not work on Arch. The problem is that the keysyms differ, see:

perldoc -m Gtk2::Gdk::Keysyms:

generated from /usr/include/gtk-2.0/gdk/gdkkeysyms.h
package Gtk2::Gdk::Keysyms;
%Gtk2::Gdk::Keysyms = (
   'KEY_VoidSymbol' => 0xffffff,
   'KEY_BackSpace' => 0xff08,
   'KEY_Tab' => 0xff09,
   'KEY_Linefeed' => 0xff0a,
   'KEY_Clear' => 0xff0b,
   'KEY_Return' => 0xff0d,
   'KEY_Pause' => 0xff13,
   'KEY_Scroll_Lock' => 0xff14,
   'KEY_Sys_Req' => 0xff15,
   'KEY_Escape' => 0xff1b,
   'KEY_Delete' => 0xffff,
   'KEY_Multi_key' => 0xff20,
   'KEY_Codeinput' => 0xff37,
   'KEY_SingleCandidate' => 0xff3c,
   'KEY_MultipleCandidate' => 0xff3d,
   'KEY_PreviousCandidate' => 0xff3e,
   'KEY_Kanji' => 0xff21,
   'KEY_Muhenkan' => 0xff22,
   'KEY_Henkan_Mode' => 0xff23,
   'KEY_Henkan' => 0xff23,

On Ubuntu and most other distributions it is 'Escape' => 0xff1b instead of 'KEY_Escape' => 0xff1b.

JF Ostiguy (jfostiguy) wrote :

I have the same problem on Gentoo amd64 (uses x11-libs/gtk+-2.22.1-r1). Very annoying.

This is due some changes in the gtk2-perl bindings. You can follow the discussion here:
http://markmail.org/thread/dbzl5npz6i2tlrzp

I am already looking for a solution / workaround.

Changed in shutter:
milestone: none → 0.87.1
assignee: nobody → Mario Kemper (Romario) (mario-kemper)
importance: Undecided → Medium
status: New → Confirmed
Changed in shutter:
milestone: 0.87.1 → 0.87.2
Ngo Ky Lam (haihoa+launchpad) wrote :

Same problem on Archlinux

Some more information:
http://markmail.org/thread/r2ntn66xiljt2uf5

I don't think we need to change anything here. Just wait for the next gtk2-perl release.

Photon (michael-kogan) wrote :

Seems to be fixed now.

Changed in shutter:
status: Confirmed → Fix Committed
Changed in shutter:
milestone: 0.87.2 → 0.87.1
Changed in shutter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers