Shutter - Screenshot Tool

Selection tool leave artifact on every second image capture

Reported by MONDARIZ on 2010-05-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Shutter
Medium
Mario Kemper (Romario)

Bug Description

Using Shutter V 085.1 on Ubuntu 10.04 LTS.

When capturing an area, the selection tools border (dotted line) is visible in the captured image. However, when I capture the next image, this is no longer the case.

Feel free to contact me for screenshots (no joke intended)

summary: - Selection tool leave artifact on ever second image capture
+ Selection tool leave artifact on every second image capture
Vadim Rutkovsky (roignac) wrote :

Could you please attach the screenshots?
I was able to reproduce the dotted line only under a heavy CPU load.

MONDARIZ (mail-retrodata) wrote :

Here is the screenshot with artifact.

Unlike you, my PC is under absolutly no strain - running only OS, Firefox and Shutter.

MONDARIZ (mail-retrodata) wrote :

Just to clarify the bug I have attached the following screenshot, where the border is no longer visible. I find it significant, that the artifact only appears on every second image.

MONDARIZ (mail-retrodata) wrote :

I have reinstalled Shutter and the problem seems to have dissapeared. I will keep monitoring it, but for now you can consider the bug closed.

MONDARIZ

Vadim Rutkovsky (roignac) wrote :

Closed bu as "Invalid" as it is not reproducable any more.

Changed in shutter:
status: New → Invalid
MONDARIZ (mail-retrodata) wrote :

Sorry to report that the issue has reappeared.

Could you please increase the "Redraw Delay" and test if this makes any difference. You can find the setting in Shutter's preferences, see:
http://www.ubuntu-pics.de/bild/73334/shutter___preferences_KJRM9q.png

Changed in shutter:
status: Invalid → Confirmed
MONDARIZ (mail-retrodata) wrote :

Hi Mario,

Increasing the delay to maximum does not affect the issue.

What video hardware do you use? I do know another user having this
problem. He is using a nvidia graphics card.

What window manager are you using? Compiz, Metacity etc.? Could you
please check if the window manager does influence the problem?

Thank you very much for your help.

MONDARIZ (mail-retrodata) wrote :

Yes, I'm using a Nvidia GeForce 9800GT graphics card (using Nvidia X Server 11.0 and driver 195.36.15) with default settings (no antialiasing, or other filtering).

I'm using the standard Ubuntu Gnome windows manager. No special frills.

I have been using Shutter for about 4 months and the bug only appeared with the last update.

MONDARIZ

Vadim Rutkovsky (roignac) wrote :

I also have Nvidia video card, proprietary drivers and can reproduce the issue (randomly). Need someone with Nouvea drivers or ATI video card - I guess the problem derives from proprietary drivers

MONDARIZ (mail-retrodata) wrote :

I have now swapped graphics driver and can confirm that the issue is related to the Nvidia proprietary driver. As far as I'm concerned the issue is resolved, since Shutter have no reason to support proprietary drivers. However, I will be available to assist in any way i can, if you choose to fix the issue.

In the mean time i will use the Nouvea driver.

MONDARIZ

Is this still valid? Please use the latest version 0.86.3.

Hi,

Not sure, I'm not using Ubuntu at the moment.

Jan

On 19-08-2010 13:48, Mario Kemper (Romario) wrote:
> Is this still valid? Please use the latest version 0.86.3.
>
>

Nick Read (nickread) wrote :

I can confirm that this bug is happening to me in 0.86.4 on Maverick beta. It has been happening for a long time (using the ppa for Lucid and Karmic) and I assumed it would be fixed. As it is still happening, I decided to report it since I'm getting sick of manually cropping out the border.

I too am using the proprietary Nvidia driver - the performance of 3D in Nouveau prevents it from being a viable option for my work at this time (fingers crossed for the future though).

Also seeing this from time to time in shutter 0.86.3 on Ubuntu 10.10.

@Ralf: Are you using the proprietary Nvidia driver, as well? Does this also happen when setting delay to 0?

Changed in shutter:
assignee: nobody → Mario Kemper (Romario) (mario-kemper)
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers