Comment 14 for bug 511942

Is it possible to patch the current package in 10.04? I'd prepare a fix for this bug if possible.