Shutter - Screenshot Tool

Shutter silently fails to set hotkeys with Compiz’s flat-file backend

Reported by Alex Bepple on 2009-11-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shutter
Low
Mario Kemper (Romario)

Bug Description

I had tried to set Shutter as the default screenshot tool from its preferences dialog to no avail. Nothing happened. I finally succeeded via the CompizConfig Settings Manager.

I was about to report a problem when I found out that Compiz needs to use the GConf backend in order for this to work (https://bugs.launchpad.net/shutter/+bug/348595).

There are good reasons not to use the GConf backend in Compiz. Shutter should deal with such a setup more gracefully:
* Either find a different way to integrate with Compiz or
* Warn the user that she needs to use GConf backend in Compiz for this to work.

Shutter v0.80.1, r579
Linux Mint Gloria

Id say we should report the error to the user.

On Nov 11, 2009 10:20 PM, "Alex Bepple" <email address hidden> wrote:

Public bug reported:

I had tried to set Shutter as the default screenshot tool from its
preferences dialog to no avail. Nothing happened. I finally succeeded
via the CompizConfig Settings Manager.

I was about to report a problem when I found out that Compiz needs to
use the GConf backend in order for this to work
(https://bugs.launchpad.net/shutter/+bug/348595).

There are good reasons not to use the GConf backend in Compiz. Shutter
should deal with such a setup more gracefully:
* Either find a different way to integrate with Compiz or
* Warn the user that she needs to use GConf backend in Compiz for this to
work.

Shutter v0.80.1, r579
Linux Mint Gloria

** Affects: shutter
    Importance: Undecided
        Status: New

--
Shutter silently fails to set hotkeys with Compiz’s flat-file backend
https://bugs.launchpad.net/bugs/481096
You received this bug notification because you are a member of Shutter
Team, which is subscribed to Shutter.

I agree.

Changed in shutter:
assignee: nobody → Mario Kemper (Romario) (mario-kemper)
importance: Undecided → Low
milestone: none → 0.86
status: New → Fix Committed
status: Fix Committed → Confirmed
Changed in shutter:
milestone: 0.86 → 0.87

Errors will be reported now. Please reopen this bug if anything does not work as expected.

Changed in shutter:
status: Confirmed → Fix Committed
Changed in shutter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers