Add a callout editing tool for quick annotations

Bug #349048 reported by Stephen Boddy on 2009-03-26
4
Affects Status Importance Assigned to Milestone
Shutter
Wishlist
Unassigned

Bug Description

It would be nice to have a single tool to do a callout.

See http://www.chartfu.com/images/ChartFuCallout.gif for an example.

To do this now, I have to create a line, a rectangle, and a text box. Each of these is independent, so if changing it, I may have to edit three objects.

Vadim Peretokin (vperetokin) wrote :

Yes, good suggestion.

Changed in shutter:
milestone: none → 0.85
status: New → Confirmed
Changed in shutter:
milestone: 0.85 → 0.86
Changed in shutter:
importance: Undecided → Wishlist

I've added some nice callout shapes to the DrawingTool (being released with Shutter 0.86).

Due to the fact that these files are in SVG format they can nicely be resized. There will be no built-in functionality to edit text within the callouts but you can create a textarea and move it onto the callout.

This is all I can do for now. Time is limited currently.

Changed in shutter:
status: Confirmed → Fix Committed
Changed in shutter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers