UTF (?) Bug - Polish translation

Bug #347821 reported by Krzysztof Antczak on 2009-03-24
2
Affects Status Importance Assigned to Milestone
Shutter
Medium
Mario Kemper (Romario)

Bug Description

Hi,

Today (after update - I think) i've noticed that one Polish "ó" letter has got some problems with encoding.

Statistics / Statystyka
Rozmiar całkowity: 0 bajt*ó*w <-- here are 2 UTF chars instead of "ó".

I was trying to find this word in Translations, but weird... I can't see it there.

description: updated

This only happens if there are no screenshots in session, right?

see:
http://www.ubuntu-pics.de/bild/11461/screenshot_0023_mrcbH7.png
and
http://www.ubuntu-pics.de/bild/11462/screenshot_0025_70cOON.png

It is not in the translation template because the file size is generated within a Gnome-Vfs method (Gnome2::VFS->format_file_size_for_display ($size)).

Changed in shutter:
assignee: nobody → mario-kemper
importance: Undecided → Medium
status: New → Confirmed

Seems to be a problem with other languages as well, e.g. Japanese:
http://www.ubuntu-pics.de/bild/11464/screenshot_0026_63VFWc.png

Krzysztof Antczak (k-antczak) wrote :

In Your case... right. But, when screenshot file size has ie. 645 bites, then You can see this problem again, ie.

1) 0 bajtów
2) 1 bajt
3) 2 bajty
4) 5 bajtów
5) 644 bajty
6) 645 bajtów

I know, weird Polish spelling... :)

Could you please extract and replace this file with your current /usr/bin/shutter and see if it fixes this issue?

Changed in shutter:
milestone: none → 0.70
Krzysztof Antczak (k-antczak) wrote :

Yeap, it works now. :)

Ok, I'll upload a new package tonight. Thanks for reporting this bug.

Changed in shutter:
status: Confirmed → In Progress
Changed in shutter:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments