When taking a selection screenshot, shutter window partially overlays

Bug #340856 reported by Mark Grandi on 2009-03-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shutter
Medium
Mario Kemper (Romario)

Bug Description

I tried to take a full screen screenshot, but after trying it for a few seconds like half of the shutter window was overlaying another window...which made it look weird. See screenshot.

Mark Grandi (markgrandi) wrote :

This a known problem.

After hiding and/or minimizing it is very hard to check whether the window really is not visible on the screen anymore because the window manager is handling the request.
It is even harder to work around this issue as more and more users are using compiz and nice effects are added by the window manager.

In older versions we used just a simple 'sleep %seconds' statement but there are some great disadvantages. Users with very fast machines may recognize an improvement but users with very old system (this bug usually is not present there) need to wait a second where it would not be needed.

I think we need a 'real' solution here because it will never be solved totally when dealing with fixed seconds to sleep before taking the screenshot.

Changed in shutter:
assignee: nobody → mario-kemper
importance: Undecided → Medium
status: New → Confirmed
Vadim Peretokin (vperetokin) wrote :

For now, you can set a delay in preferences to make shutter wait a bit after hiding and before taking the screenshot.

I'm not sure if this is solvable - in gtk docs it says to never assume that the window really is hidden since the WM might still be doing something with it, and it doesn't mention about a signal we can use. I'll see if I can ask about though...

Compiz people said to "check _NET_WM_STATE for _NET_WM_STATE_HIDDEN". Would
that work?

I'll check that...

Changed in shutter:
milestone: none → 0.70
status: Confirmed → In Progress
Changed in shutter:
status: In Progress → Fix Committed
Changed in shutter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers