Copy URL to clipboard after uploading to a FTP Server

Bug #339920 reported by Mario Kemper (Romario) on 2009-03-09
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Shutter
Wishlist
Mario Kemper (Romario)

Bug Description

Needs to be implemented.

Multiple upload:
When uploading multiple screenshots the last URL should be copied to clipboard.

Vadim Peretokin (vperetokin) wrote :

I don't think this is useful because paths on the server and urls can be different.

Krzysztof Antczak (k-antczak) wrote :

I don't see any problem... It should be provided in settings - look at JING from techsmith… There is no such problem there, and it's really usefull thing, ie.

1) Website URL: http://example.com/shots/
2) Website FTP: example.com
3) Website Login: foo
4) Website Password: bar
5) Website remote dir: domains/example.com/public_html/shots/

After uploading, target URL is ie.: http://example.com/shots/%D-%M-%Y_%T.jpeg

Yeah! Made it simple! :)

Vadim Peretokin (vperetokin) wrote :

Yep that would work. Maybe just http://example.com/shots/%filename%

Changed in shutter:
status: New → Confirmed

Sounds good.
So we need an additional entry field (website url) in the upload settings, is that right?
After uploading to this ftp server we switch the %filename% placeholder to the real filename and if there is no %filename% we append it to the URL. Would this be ok?

Finally this URL would be copied to clipboard...

Krzysztof Antczak (k-antczak) wrote :

Exactly :)

In the preferences, not upload dialog

On Thu, Mar 12, 2009 at 4:07 PM, Mario Kemper (Romario) <
<email address hidden>> wrote:

> Sounds good.
> So we need an additional entry field (website url) in the upload settings,
> is that right?
> After uploading to this ftp server we switch the %filename% placeholder to
> the real filename and if there is no %filename% we append it to the URL.
> Would this be ok?
>
> Finally this URL would be copied to clipboard...
>
> --
> Copy URL to clipboard after uploading to a FTP Server
> https://bugs.launchpad.net/bugs/339920
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ok, we need it in both.
The FTP Server configured in the preferences is "mirrored" to the upload dialog.

@Vadim: Could you please name a nice tooltip text for this additional field?

Vadim Peretokin (vperetokin) wrote :

I don't think it needs to be in the upload dialog at all - this isn't something that you'll be changing frequently, and the point of preferences dialog is ah have all the preferences in it.

The tooltip will need to be done later when the implementation is in so it's most accurate

Changed in shutter:
milestone: none → 0.90

fixing together with bug #341810

Changed in shutter:
assignee: nobody → Mario Kemper (Romario) (mario-kemper)
importance: Undecided → Wishlist
milestone: 0.90 → 0.85

see bug #341511 as well

Changed in shutter:
milestone: 0.85 → 0.86
Changed in shutter:
status: Confirmed → In Progress
Changed in shutter:
status: In Progress → Fix Committed
Changed in shutter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers