Shutter - Screenshot Tool

When using a metacity theme with rounded corners, corners are not transparent

Reported by Christoph Langner on 2008-08-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shutter
Medium
Mario Kemper (Romario)

Bug Description

When you use a metacity theme with rounded corners and you make a screenshot of a window, the corners are not transparent. You can see e.g. your desktop background instead of a transparent area. Compare the behaviour with the gnome screenshot tool. It doesn't matter if you use compiz or metacity as window manager.

Christoph Langner (chrissss) wrote :

I'll have a look, thanks for your bug report.

Changed in gscrot:
assignee: nobody → mario-kemper
importance: Undecided → Medium
status: New → Confirmed

No real solution yet, still working on it...

We surely have to use this module to deal with it:
http://search.cpan.org/~smccam/X11-Protocol-0.56/Protocol/Ext/SHAPE.pm

Changed in gscrot:
milestone: none → 0.70
status: Confirmed → In Progress
Changed in gscrot:
status: In Progress → Fix Committed
Changed in shutter:
status: Fix Committed → Fix Released
Christoph Langner (chrissss) wrote :

I reopen here. I installes shutter 0.7

§ dpkg -l shutter | grep ii
ii shutter 0.70~ppa11

When i make a screenshot of a window (i'm using shiki as my desktop theme here) i see the gray background from my wallpaper but no transparency.

Changed in shutter:
status: Fix Released → New
Christoph Langner (chrissss) wrote :

A Screenshot to explain this better. The marked corner should be transparent.

Are you using compiz?

Christoph Langner (chrissss) wrote :

> Are you using compiz?

I tried metacity and compiz. It doesn't make a difference.

And you are using png as filetype?

Christoph Langner (chrissss) wrote :

Yes.

It does happen sometimes here but I can't find a reproducible way yet

Vadim Peretokin (vperetokin) wrote :

found another case, see top-left on this one:

http://www.ubuntu-pics.de/bild/10613/screenshot_100_508__2o3qVg.png

(stats a different site)

Christoph Langner (chrissss) wrote :

Ah, i think i found the answer. Start metacity before you take a screenshot

$ metacity --replace &
$ shutter

-> Corners are transparent

Switch to metacity AFTER you started shutter

$ compiz --replace &
$ shutter
$ metacity --replace &

-> And you'll get opaque window corners

Oh, this is correct.
Shutter initializes the X11 protocol connection on startup. At this point the XSHAPE extension is loaded as well. Maybe we can catch a signal when wm was changed, so we can init X11 again.

@Christoph: Do you agree that this would be a valid solution or is anything else not working here?

Changed in shutter:
status: New → Confirmed
Christoph Langner (chrissss) wrote :

@Mario: Yep, that would be a valid solution. For me it's quite important to be able to take screenshots with transparent corners since i have to include them into documentations or reports. But i also like desktop effects while working. So i switch between metacity and compiz to get the transparent corners, but it would be easier not to need restart shutter too :)

Changed in shutter:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers