Error connecting when upload to public hosting

Bug #1791503 reported by Jeff Compton on 2018-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shutter
Undecided
Unassigned

Bug Description

When trying to upload a screenshot to any of the default hosters, e.. ITmages:

File does not exist: Can't connect to itmages.com:80 (Connection refused)

Connection refused at /usr/lib/perl5/vendor_perl/5.26.1/LWP/Protocol/http.pm line 50.
 at /usr/share/shutter/resources/system/upload_plugins/upload/ITmages.pm line 115.

Shutter Version: Shutter 0.94 Rev. 1290
Distribution: OpenSuse Leap 15
uname -r: 4.12.14-lp150.12.16-default

Photon (michael-kogan) wrote :

Yes, many of the upload plugins are outdated and broken. Imgur Guest upload works for me though.

Jeff Compton (jcompton) wrote :

Strange, Imgur is the one I had tried first, and it didn't work... but now it does.

This makes Shutter a really valuable tool... thank you!

Photon (michael-kogan) wrote :

The ITmages service is actually not available any more, the website is down: http://web.archive.org/web/*/itmages.com I removed the plugin in rev. 1296.

Same holds for the Minus plugin: http://web.archive.org/web/*/http://www.minus.com/ I removed the plugin in rev. 1297.

ToileLibre is currently down, but seems to have worked recently: http://web.archive.org/web/*/toile-libre.org I leave the plugin for now, maybe the service will return soon.

Changed in shutter:
status: New → Fix Committed
Photon (michael-kogan) on 2018-09-09
Changed in shutter:
milestone: none → 0.94.1
Photon (michael-kogan) on 2018-09-09
Changed in shutter:
status: Fix Committed → Won't Fix
milestone: 0.94.1 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers