illegal characters from window name in filename causes failure to save screenshot

Bug #1651568 reported by Jurriaan Den Toonder on 2016-12-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shutter
Undecided
Unassigned

Bug Description

Shutter version: 0.92 Rev.1269
Linux Distribution: Ubuntu 15.10

When taking screenshots of a window with the | character in the window title results in a failure to take and save said screenshot.

1. Turn on automatic saving of screenshots with the following filename: $name_%NNN (Preferences -> Main -> Automatically save file)
2. Navigate to a website that has an | character in the window title. (https://plot.ly/~Fastjur/1.embed?share_key=kMkAz68LOJwxqswzJriryl)
3. Use the "Window" screenshot feature and select the browser.

This results in an error (can be seen in the attachment)

Jurriaan Den Toonder (fastjur) wrote :
Photon (michael-kogan) wrote :

Seems like a duplicate of https://bugs.launchpad.net/shutter/+bug/1556021 Could you please test the most recent bzr revision if the problem is solved for you? Thanks!

Changed in shutter:
status: New → Incomplete
Jurriaan Den Toonder (fastjur) wrote :

Hi, after updating I can confirm it works so it was indeed a duplicate of https://bugs.launchpad.net/shutter/+bug/1556021

Thanks!

Changed in shutter:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers