imgur upload plugin no longer works due to now unsupported API 1 and 2

Bug #1565048 reported by Rik Mills on 2016-04-01
112
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Shutter
Undecided
Timothy Zorn
shutter (Ubuntu)
Undecided
Unassigned

Bug Description

Shutter v0.93.1
Ubuntu xenial (16.04)

imgur upload plugin no longer works due to now unsupported API 1 and 2

error connecting message on attempted upload with the plugin

AP1 1 and 2 urls on their site now display this message:

> API no longer available - Updated March 30, 2016
> As of March 28, 2016, versions 1 and 2 of the Imgur API are no longer supported.
> If you manage an application which relies on the API, we encourage you to migrate your application to Imgur API version 3.
> If you need some assistance with that, feel free to check out api.imgur.com for documentation.
> If your application uses authorization, you will also need to upgrade to oauth 2.0.
> If you have any questions, we’d be happy to help at <email address hidden>.

CodyMKW (codybug1991) wrote :

I can also confirm this the same happens on Ubuntu MATE 15.10

Cthulhu (filodoksos) wrote :

I too confirm for Ubuntu 14.04

Dev Null (superpenguinpower) wrote :

Add me to the list. Ubuntu 14.04

Rik Mills (rikmills) wrote :

To fix seems to need:

(1) registration/obtaining a clinet ID from imgur for their v3 api.

Needs a "Authorization: Client-ID YOUR_CLIENT_ID" header sent with the POST request

(2) Modification of the POST request to add that header and use the v3 api url endpoint

(3) As the format of the json response for v3 api is very different, upload plugin code needs amending to properly extract and format the image and delete urls, to then return to the main shutter application.

Rik Mills (rikmills) wrote :

Have achieved (1) and (2) here, but my limited perl means I'll struggle on (3) I think

Rik Mills (rikmills) wrote :

A probably imperfect patch.

Needs a client ID to be registered and 'YOUR_CLIENT_ID' in code/patch replaced with that.

Alan Worstell (aworstell) wrote :

Chiming in to note that this is broken in Fedora 23 as well.

Bernardo (bbernardoleon) wrote :

Ubuntu 14.04. I confirm this issue too.

kabeza (kabeza) wrote :

Confirmed here too
elementary OS 0.3.2 Freya
Shutter 0.90.1

Thanks

Tux (tux3-hotmail) wrote :

Also happens with Shutter 0.93.1, Debian Sid
Unfortunately, I don't know any Perl.

jokrebel (jokrebel) wrote :

same on Ubuntu 14.04.4, 16.04 and 16.10 as well as on siduction
Shutter version 0.90.x - 0.93.x

Changed in shutter:
status: New → Confirmed
n[oO]ne (noone-x) wrote :

A patch with a client id.

No images get attached to this account.

Removed anything from output window, except: Image url, Delete url, Thumbnail small, medium, large and huge.

n[oO]ne (noone-x) wrote :

This is the Imgur.pm as a drop-in replacement, i found it in: /usr/share/shutter/resources/system/upload_plugins/upload/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shutter (Ubuntu):
status: New → Confirmed

The attachment "Imgur_upload.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sparhawk (sparhawkthesecond) wrote :

I can confirm that replacing /usr/share/shutter/resources/system/upload_plugins/upload/Imgur.pm with n[oO]ne's version fixes this problem. Thank you! However, the order of the urls is slightly odd:

* Thumbnail large
* Thumbnail small
* Delete url
* Image url
* Thumbnail huge
* Thumbnail medium

skorasaurus (skoraw) wrote :

I can also confirm that n[oO]ne's .pm file at https://bugs.launchpad.net/shutter/+bug/1565048/comments/14 enables users to upload images to imgur again and fixes this bug.

After replacing the old, you'll also need to give execute permissions to Imgur.pm

I'm using 0.93.1 of shutter, rev.1278

Dev Null (superpenguinpower) wrote :

Just reviewed and tested Imgur.pm revised by n[oO]ne. Yay, it works. Thanks!

Timothy Zorn (systemdisc) wrote :

My fix allows Imgur Guest to work again, but also adds Imgur OAuth: https://code.launchpad.net/~systemdisc/shutter/imgur-fix/+merge/313977

Photon (michael-kogan) wrote :

I can confirm the fix by Timothy Zorn to be working and included it into Arch's Shutter package.

Phil (phd21) wrote :

Hi Everyone,

Could any of you please explain to me so I can explain to others, where I can download these updated file(s), and how to install them? Do I need to download just the "imgur.pm" file, or are there other files needed to get this working with "imgur", if so where? Are there new Shutter ".deb" packages available or a PPA for these updates?

FYI: I am using Linux Mint 17.3 KDE and Linux Mint 18.1 KDE and using the "shutter-testing-team" PPA to keep my Shutter application updated, is this the correct one? Have these changes been uploaded to the Shutter PPAs?

Also, since all of you seem good at this, have you come up with other ".pm" files for other image hosting services like "postimage.org", etc...? It would be really nice if Shutter had a configuration option to add other image hosts as well based upon the host's authentication method ...

Best regards to all of you,
Phil
phd21
<email address hidden>

Why did this PR is not merged?

Photon (michael-kogan) on 2017-08-11
Changed in shutter:
status: Confirmed → Fix Committed
assignee: nobody → Timothy Zorn (systemdisc)
Photon (michael-kogan) on 2017-08-14
Changed in shutter:
milestone: none → 0.94
Photon (michael-kogan) on 2017-08-16
Changed in shutter:
status: Fix Committed → Fix Released
Changed in shutter (Ubuntu):
status: Confirmed → Invalid

I'm using shutter 0.94-1 on Xubuntu 18.04, and Imgur OAuth works but it repeats the authorization process before every upload, even though shutter is authorized to use my imgur account:

https://i.imgur.com/PVgMFy4.png

I filed bug #1782646

I forgot to mention: upload to "Imgur Guest" is working fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments