Shutter - Screenshot Tool

Imgur plugin doesn't work

Reported by Daniel Leining on 2012-07-05
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Shutter
High
Mario Kemper (Romario)

Bug Description

When trying to export to Imgur, it fails, showing an error box. It says "Error while connecting" , and something about a malformed JSON string. (I will include a screenshot.) This happens on Shutter 0.88.3 Rev 1206 in Arch Linux, and also happens on Ubuntu 12.04.

Edit: Imgur isn't the only one--
ImageShack Guest: Not working
Minus: Authenticated doesn't upload as your user, always uploads as guest. Also, doesn't give a direct link. Works though.

I've got this issue as well.
On Jul 5, 2012 5:45 PM, "Daniel Leining" <email address hidden> wrote:

> Public bug reported:
>
> When trying to export to Imgur, it fails, showing an error box. It says
> "Error while connecting" , and something about a malformed JSON string.
> (I will include a screenshot.) This happens on Shutter 0.88.3 Rev 1206
> in Arch Linux, and also happens on Ubuntu 12.04.
>
> ** Affects: shutter
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of Shutter
> Team, which is subscribed to Shutter.
> https://bugs.launchpad.net/bugs/1021158
>
> Title:
> Imgur plugin doesn't work
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/shutter/+bug/1021158/+subscriptions
>

Changed in shutter:
assignee: nobody → Mario Kemper (Romario) (mario-kemper)
importance: Undecided → Low
milestone: none → 0.88.4
status: New → Confirmed
Daniel Leining (luminary) wrote :

I've added a couple of other upload bugs to the bug description.

description: updated
Changed in shutter:
milestone: 0.89 → upload
importance: Low → High
Changed in shutter:
status: Confirmed → Fix Committed
milestone: upload → 0.89.1
pt123 (pt123) wrote :

this bug still appears on the latest version from the ppa rev 1219 ( is it possible to show the full version number in the about dialog box)

malformed JSON string, neither array, object, number, string or atom, at character offset 0 (before "=J.nodeName(c,"input...") at /usr/share/shutter/resources/system/upload_plugins/upload//Imgur.pm line 118.

Changed in shutter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers