Uses excessive memory on import

Bug #588569 reported by Chris Halse Rogers on 2010-06-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Shotwell
New
Unknown
shotwell (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: shotwell

Shotwell appears to have a memory leak on import. Importing a folder of 133 RAW images totalling 1.6GiB results in a peak physical memory usage of about 1.2GiB. The memory usage fluctuates with each image imported, going both up and down, but there's a significant per-photo increase in memory usage.

The memory is not freed after the import is finished. The memory usage on fresh startup is ~40 MiB.

This also occurs with a folder full of JPEG files, but the per-image and total memory usage is about 10 times lower, so it's far less noticable.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: shotwell 0.5.90-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.34-5.12-generic 2.6.34
Uname: Linux 2.6.34-5-generic x86_64
Architecture: amd64
Date: Wed Jun 2 12:00:07 2010
ExecutablePath: /usr/bin/shotwell
ProcEnviron:
 LANGUAGE=en_AU:en_GB:en
 LANG=en_AU.utf8
 SHELL=/bin/zsh
SourcePackage: shotwell

Chris Halse Rogers (raof) wrote :
Jim Nelson (yorba-jim) wrote :

Recorded on our Trac at http://trac.yorba.org/ticket/1998

Omer Akram (om26er) wrote :

this bug is fixed upstream.

Changed in shotwell (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Changed in shotwell:
status: Unknown → Fix Released
markgalassi (mark-galassi) wrote :

Someone reported 1.2gig of memory use for a small problem. I just want to add that in my case it reaches past 11gig before I shut it down.

 5116 markgala 20 0 11.1g 4.9g 3752 T 0 87.2 27:45.98 shotwell

Omer Akram (om26er) wrote :

markgalassi, which version are you using?

Omer Akram (om26er) wrote :

shotwell 0.6.1 is in Maverick.

Changed in shotwell (Ubuntu):
status: Fix Committed → Fix Released
everflux (tklaunchpad) wrote :

Currently 0.7.2 is in maverick and import from f-spot with 20.000 pictures crashes my 8GB machine (out of memory). It seems that shotwell is leaking memory when creating thumbnails.
According to the yorba ticket system the current discussion focuses on the situation *after* the import - but shotwell is unable to scale _during_ the import. This should be fixed, or a multi-step import could be used as a work around.

Jim Nelson (yorba-jim) wrote :

everflux,

This is a separate problem than the one reported here. Our ticket for this problem is at http://trac.yorba.org/ticket/2566

-- Jim

Dave (filosofic) wrote :

Clean install of 11.04 and import of photos folder containing over 26,000 photos at 90 GB leads Shotwell 0.9.3 to run at 108% on Quadcore AMD CPU (now 112% -- higher at times) and using 2.5 GB of RAM. Use of RAM keep climbing until maxing out my 4 GB and Shotwell crashes.

Eric Gregory (eric-yorba) wrote :

We will try to repro in house. However, this sounds like potentially a different issue than the one in the bug (the fix for this was already verified.)

Vera Yin (vera-yorba) wrote :

I have not been able to reproduce the memory leak on 11.04 with either Shotwell 0.9.3 or the current 0.10+trunk. My Quadcore CPU runs as high as 240%, but memory usage does not climb above 200MB for importing 30,000 photos.

When importing RAW photos (about 100 files totaling 1GB), memory usage spiked to as high as 500MB but would settle back to 200MB between each photo and after completing the import.

Questions for Dave:
* Were RAW files imported and if so, what kind?
* How was Shotwell installed - from the Yorba PPA or built from source?

Hi Vera,
About 1/3 of the photos would have been RAW, no more, taken with Nikon
digital SLRs, so NEF file formats.
Shotwell was installed as part of the regular Ubuntu 11.04 installation
process. No special debs or ppas involved.
I will try to reproduce myself again to confirm. I've found Unity to have
some problems so will also log into Ubuntu Classic and see if I can
reproduce.

David Schult
Si hoc legere scis, nimis eruditionis habes.
https://sites.google.com/site/filosofic/

On Wed, Jun 1, 2011 at 12:46, Vera Yin <email address hidden> wrote:

> I have not been able to reproduce the memory leak on 11.04 with either
> Shotwell 0.9.3 or the current 0.10+trunk. My Quadcore CPU runs as high
> as 240%, but memory usage does not climb above 200MB for importing
> 30,000 photos.
>
> When importing RAW photos (about 100 files totaling 1GB), memory usage
> spiked to as high as 500MB but would settle back to 200MB between each
> photo and after completing the import.
>
> Questions for Dave:
> * Were RAW files imported and if so, what kind?
> * How was Shotwell installed - from the Yorba PPA or built from source?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/588569
>
> Title:
> Uses excessive memory on import
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/shotwell/+bug/588569/+subscribe
>

Changed in shotwell:
status: Fix Released → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.