not installed

Bug #997172 reported by Narcis Buisac i Mas on 2012-05-09
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Ubuntu Server Guide
Peter Matulis
smbldap-tools (Debian)
smbldap-tools (Ubuntu)
Nish Aravamudan

Bug Description

Installing and configuring LDAP and Samba, beg¡fore execute the command smbldap-populate we must uncompress a files that in this version of smbldap-tools (from Ubuntu 12.04) it is not present. I refer the or better the

without it we cannot generate the smbldap.conf nor smbldap_bind.conf before execute the smbldap-populate command to Add Samba LDAP objects to my ldap.


Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in smbldap-tools (Ubuntu):
status: New → Confirmed
Ric_CR (ricsv-cr) wrote :

I installed the amd64 package version, not sure if this is only affecting amd64 or x86 as well. Just wanted to point that out.

Mogidin (mogidin) wrote :

I copy from ubuntu 10.04 and correct it

işbaran akçayır (isbaran) wrote :

It was renamed to but is not included in deb package

Peter Matulis (petermatulis) wrote :

It's there for me, on Precise at least.

$ apt-get source smbldap-tools
$ cd smbldap-tools-0.9.7
$ find . -name

I'm marking as 'Invalid' unless you prove it's not there for a particular release. If you do, mark it as affecting that release.

I will be applying this towards the serverguide project however as the Guide does still mention

Changed in smbldap-tools (Ubuntu):
status: Confirmed → Invalid
Changed in serverguide:
status: New → Confirmed
assignee: nobody → Peter Matulis (petermatulis)
importance: Undecided → Medium
Peter Matulis (petermatulis) wrote :

Hm, after actual package installation I do see that the helper script is not installed. Workaround is to configure smbldap.conf manually. Marking back to 'Confirmed'.

Changed in smbldap-tools (Ubuntu):
status: Invalid → Confirmed
summary: - LDAP and Samba.
+ not installed
Changed in serverguide:
status: Confirmed → Fix Committed
Changed in smbldap-tools (Debian):
status: Unknown → New
Matt Rae (mattrae) wrote :

To use the (also named smbldap-config) you can download the source package and run the following commands to configure and run the script:

$ apt-get source smbldap-tools
$ perl ./smbldap-tools-0.9.7/
$ cd smbldap-tools-0.9.7/
$ ./configure
$ make
$ ./smbldap-config.cmd

Changed in serverguide:
status: Fix Committed → Fix Released
Theodor van Nahl (tvn87) wrote :

What is the current status of this bug?

The server documentation still mentions the and the as well as the are not in the current smbldap-tools nor in any other precise pakage.

Bryan Quigley (bryanquigley) wrote :

I though this would pull here from the Debian bug:
Upstream has fixed their makefile to include building and installing
Once pulled into Debian/Ubuntu this should fix the issue (this won't help 12.04). It's fixed in the just released 0.9.10 release.

This should definitely be a candidate to SRU to 12.04. (I was hoping Debian would pull it before requesting it, but guess we don't need to wait)

Doug Smythies (dsmythies) wrote :

The serverguide tends to be edited for new cycles only, and not retro edited. Why? Because nobody helps with it, and there are not enough resources.
Look at the 12.10 version of the serverguide, where this specific bug report is referenced and it says:

Next, configure the smbldap-tools package to match your environment. The package is supposed
to come with a configuration helper script (, formerly that will ask
questions about the needed options but there is a bug37 whereby it is not installed (but found in the
source code; 'apt-get source smbldap-tools').

Robert Green (rlg-d) wrote :

I am new to server administration and am having trouble with smbldap-tools. I have followed some instructions I have read on this foram. I have downloaded the source for smbldap-tools. When I tried to configuer it I got the error mesage: can't exec @perl_cmd@ at ./smbldap-tools-0.9.7/ line 1. I thank you in advansed for any help you can give me

Vazhnov Alexey (vazhnov) wrote :

Bug in still not fixed. Just copy text «Adding Samba LDAP objects…» from

Jeff Prince (princej) wrote :

I am seeing the same problem as Robert Green. Mine is version 0.9.9.

root@dengis01p:/etc/ldap/schema/smbldap-tools-0.9.9# perl ./
Can't exec @PERL_COMMAND@ at ./ line 1.

Which leaves me stuck on the smbldap populate step found here:

root@dengis01p:/etc/ldap/schema/smbldap-tools-0.9.9# smbldap-populate
Unable to open /etc/smbldap-tools/smbldap.conf for reading !
Compilation failed in require at /usr/sbin/smbldap-populate line 30.
BEGIN failed--compilation aborted at /usr/sbin/smbldap-populate line 30.

Nish Aravamudan (nacc) wrote :

I am going to work on backporting to the 16.04 version of samba.

Changed in smbldap-tools (Ubuntu):
assignee: nobody → Nish Aravamudan (nacc)
Nish Aravamudan (nacc) wrote :
Changed in smbldap-tools (Ubuntu):
status: Confirmed → In Progress
Nish Aravamudan (nacc) wrote :

I've backported the appropriate fixes to the Yakkety version of smbldap-tools. Once it's accepted there, I can file an SRU for 16.04 and 14.04.

Changed in smbldap-tools (Ubuntu):
importance: Undecided → Medium
tags: added: patch
tags: added: precise trusty xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.