[SRU] smbldap-config.pl not installed

Bug #997172 reported by Narcis Buisac i Mas on 2012-05-09
140
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Ubuntu Server Guide
Medium
Peter Matulis
smbldap-tools (Debian)
New
Unknown
smbldap-tools (Ubuntu)
Medium
Nish Aravamudan
Trusty
Medium
Nish Aravamudan
Xenial
Medium
Nish Aravamudan

Bug Description

[Impact]

 * The serverguide currently calls out this bug and requires manual download and extraction of a source package because smbldap-config.pl is not present in the binary smbldap-tools package.

 * Add smbldap-config.pl appropriately to the Makefile to install it.

[Test Case]

 * Install smbldap-tools, smbldap-config.pl will not be present.

[Regression Potential]

 * The risk of regression is low to none, in this case, as the only effective change is the installation of a new Perl script on upgrade.
 * The only concern would be if a user manually extracted the same script from the source package and then installed the SRU'd version of smbldap-tools, but I believe dpkg will handle that case correctly.

---

Installing and configuring LDAP and Samba, beg¡fore execute the command smbldap-populate we must uncompress a files that in this version of smbldap-tools (from Ubuntu 12.04) it is not present. I refer the configure.pl.gz or better the
/usr/share/doc/smbldap-tools/configure.pl.gz
file.

without it we cannot generate the smbldap.conf nor smbldap_bind.conf before execute the smbldap-populate command to Add Samba LDAP objects to my ldap.

Thenks

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in smbldap-tools (Ubuntu):
status: New → Confirmed
Ric_CR (ricsv-cr) wrote :

I installed the amd64 package version, not sure if this is only affecting amd64 or x86 as well. Just wanted to point that out.

Mogidin (mogidin) wrote :

I copy configure.pl from ubuntu 10.04 and correct it
http://ubuntuforums.org/showpost.php?p=11825054&postcount=9

işbaran akçayır (isbaran) wrote :

It was renamed to smbldap-config.pl but is not included in deb package

Peter Matulis (petermatulis) wrote :

It's there for me, on Precise at least.

$ apt-get source smbldap-tools
$ cd smbldap-tools-0.9.7
$ find . -name smbldap-config.pl
./smbldap-config.pl

I'm marking as 'Invalid' unless you prove it's not there for a particular release. If you do, mark it as affecting that release.

I will be applying this towards the serverguide project however as the Guide does still mention configure.pl.

Changed in smbldap-tools (Ubuntu):
status: Confirmed → Invalid
Changed in serverguide:
status: New → Confirmed
assignee: nobody → Peter Matulis (petermatulis)
importance: Undecided → Medium
Peter Matulis (petermatulis) wrote :

Hm, after actual package installation I do see that the helper script is not installed. Workaround is to configure smbldap.conf manually. Marking back to 'Confirmed'.

Changed in smbldap-tools (Ubuntu):
status: Invalid → Confirmed
summary: - LDAP and Samba. configure.pl
+ smbldap-config.pl not installed
Changed in serverguide:
status: Confirmed → Fix Committed
Changed in smbldap-tools (Debian):
status: Unknown → New

To use the configure.pl (also named smbldap-config) you can download the source package and run the following commands to configure and run the script:

$ apt-get source smbldap-tools
$ perl ./smbldap-tools-0.9.7/smbldap-config.pl
$ cd smbldap-tools-0.9.7/
$ ./configure
$ make
$ ./smbldap-config.cmd

Changed in serverguide:
status: Fix Committed → Fix Released
Theodor van Nahl (tvn87) wrote :

What is the current status of this bug?

The server documentation still mentions the configure.pl.gz and the configure.pl.gz as well as the smbldap-config.pl are not in the current smbldap-tools nor in any other precise pakage.

Bryan Quigley (bryanquigley) wrote :

I though this would pull here from the Debian bug:
Upstream has fixed their makefile to include building and installing
smbldap-config.pl
(http://svn.gna.org/viewcvs/smbldap-tools/trunk/Makefile.in?r1=155&r2=156&).
Once pulled into Debian/Ubuntu this should fix the issue (this won't help 12.04). It's fixed in the just released 0.9.10 release.

This should definitely be a candidate to SRU to 12.04. (I was hoping Debian would pull it before requesting it, but guess we don't need to wait)

Doug Smythies (dsmythies) wrote :

The serverguide tends to be edited for new cycles only, and not retro edited. Why? Because nobody helps with it, and there are not enough resources.
Look at the 12.10 version of the serverguide, where this specific bug report is referenced and it says:

Next, configure the smbldap-tools package to match your environment. The package is supposed
to come with a configuration helper script (smbldap-config.pl, formerly configure.pl) that will ask
questions about the needed options but there is a bug37 whereby it is not installed (but found in the
source code; 'apt-get source smbldap-tools').

Robert Green (rlg-d) wrote :

I am new to server administration and am having trouble with smbldap-tools. I have followed some instructions I have read on this foram. I have downloaded the source for smbldap-tools. When I tried to configuer it I got the error mesage: can't exec @perl_cmd@ at ./smbldap-tools-0.9.7/smbldap-config.pl line 1. I thank you in advansed for any help you can give me

Vazhnov Alexey (vazhnov) wrote :

Bug in https://help.ubuntu.com/lts/serverguide/samba-ldap.html still not fixed. Just copy text «Adding Samba LDAP objects…» from https://help.ubuntu.com/12.10/serverguide/samba-ldap.html.

Jeff Prince (princej) wrote :

I am seeing the same problem as Robert Green. Mine is version 0.9.9.

root@dengis01p:/etc/ldap/schema/smbldap-tools-0.9.9# perl ./smbldap-config.pl
Can't exec @PERL_COMMAND@ at ./smbldap-config.pl line 1.

Which leaves me stuck on the smbldap populate step found here:

https://help.ubuntu.com/lts/serverguide/samba-ldap.html

root@dengis01p:/etc/ldap/schema/smbldap-tools-0.9.9# smbldap-populate
Unable to open /etc/smbldap-tools/smbldap.conf for reading !
Compilation failed in require at /usr/sbin/smbldap-populate line 30.
BEGIN failed--compilation aborted at /usr/sbin/smbldap-populate line 30.

Nish Aravamudan (nacc) wrote :

I am going to work on backporting http://svn.gna.org/viewcvs/smbldap-tools/trunk/Makefile.in?r1=155&r2=156& to the 16.04 version of samba.

Changed in smbldap-tools (Ubuntu):
assignee: nobody → Nish Aravamudan (nacc)
Nish Aravamudan (nacc) wrote :
Changed in smbldap-tools (Ubuntu):
status: Confirmed → In Progress

I've backported the appropriate fixes to the Yakkety version of smbldap-tools. Once it's accepted there, I can file an SRU for 16.04 and 14.04.

Changed in smbldap-tools (Ubuntu):
importance: Undecided → Medium
tags: added: patch
tags: added: precise trusty xenial
Robie Basak (racb) wrote :

Uploaded. Thanks Nish! Please remember to follow through proposed migration and to submit to Debian.

Changed in smbldap-tools (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package smbldap-tools - 0.9.9-1ubuntu2

---------------
smbldap-tools (0.9.9-1ubuntu2) yakkety; urgency=medium

  * debian/patches/0022_read_smbldap-config.patch: Install smbldap-
    config command. Closes: #697225, LP: #997172.
  * debian/patches/0023_add_pod_smbldap-config.patch: Add POD to smbldap-
    config.pl.

 -- Nishanth Aravamudan <email address hidden> Tue, 17 May 2016 15:59:40 -0700

Changed in smbldap-tools (Ubuntu):
status: Fix Committed → Fix Released

On 08.06.2016 [10:49:44 -0000], Robie Basak wrote:
> Uploaded. Thanks Nish! Please remember to follow through proposed
> migration and to submit to Debian.

Yep, I just sent via `submittodebian` in Debian Bug #697225.

summary: - smbldap-config.pl not installed
+ [SRU] smbldap-config.pl not installed
description: updated
Nish Aravamudan (nacc) wrote :
Nish Aravamudan (nacc) wrote :
Nish Aravamudan (nacc) wrote :

Hello, I have uploaded test builds to https://launchpad.net/~nacc/+archive/ubuntu/lp997172 for Trusty and Xenial.

description: updated
Robie Basak (racb) wrote :

Uploaded to Trusty and Xenial, thanks.

Note that to find SRU paperwork the SRU team follow the bug links from the changelog. In this case the second bullet doesn't have paperwork, but I know it is to fix the FTBFS based on your quilt header so I know it doesn't really need any. However this may not be clear to the SRU team, so I'm making this note here for them. It might be worth putting something like "to fix FTBFS" in the changelog entry but I've already uploaded.

Changed in smbldap-tools (Ubuntu Trusty):
status: New → In Progress
Changed in smbldap-tools (Ubuntu Xenial):
status: New → In Progress
Changed in smbldap-tools (Ubuntu Trusty):
assignee: nobody → Nish Aravamudan (nacc)
Changed in smbldap-tools (Ubuntu Xenial):
assignee: nobody → Nish Aravamudan (nacc)

Hello Narcis, or anyone else affected,

Accepted smbldap-tools into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/smbldap-tools/0.9.9-1ubuntu1.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in smbldap-tools (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in smbldap-tools (Ubuntu Xenial):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Narcis, or anyone else affected,

Accepted smbldap-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/smbldap-tools/0.9.9-1ubuntu1.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in smbldap-tools (Ubuntu Trusty):
importance: Undecided → Medium
Changed in smbldap-tools (Ubuntu Xenial):
importance: Undecided → Medium

The fix for this bug has been awaiting testing feedback in the -proposed repository for xenial for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Nish Aravamudan (nacc) wrote :
Changed in smbldap-tools (Ubuntu):
status: Fix Released → In Progress
Nish Aravamudan (nacc) wrote :

While the versions in -proposed (and actually in Yakkety) do have smbldap-config present in /usr/sbin, there is a parse error, because I typo'd the backport. I'm providing an updated debdiff for all three, and marking verification-failed for the SRU team for now.

tags: added: verification-failed
removed: verification-needed
Nish Aravamudan (nacc) wrote :
Nish Aravamudan (nacc) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package smbldap-tools - 0.9.9-1ubuntu3

---------------
smbldap-tools (0.9.9-1ubuntu3) yakkety; urgency=medium

  * debian/patches/0023_add_pod_smbldap-config.patch: Fix typo in
    backport (LP: #997172).

 -- Nishanth Aravamudan <email address hidden> Wed, 07 Sep 2016 14:03:06 -0700

Changed in smbldap-tools (Ubuntu):
status: In Progress → Fix Released

Hello Narcis, or anyone else affected,

Accepted smbldap-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/smbldap-tools/0.9.9-1ubuntu1.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
tags: removed: removal-candidate
Brian Murray (brian-murray) wrote :

Hello Narcis, or anyone else affected,

Accepted smbldap-tools into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/smbldap-tools/0.9.9-1ubuntu1.14.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Nish Aravamudan (nacc) wrote :

# apt-cache policy smbldap-tools
smbldap-tools:
  Installed: 0.9.9-1ubuntu1.16.04.2
# which smbldap-config
/usr/sbin/smbldap-config
# smbldap-config
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
       smbldap-tools script configuration
       -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Before starting, check
 . if your samba controller is up and running.
 . if the domain SID is defined (you can get it with the 'net getlocalsid')

 . you can leave the configuration using the Ctrl-c key combination
 . empty value can be set with the "." character
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Samba needs to be started first !

# apt-cache policy smbldap-tools
smbldap-tools:
  Installed: 0.9.9-1ubuntu1.14.04.2
# which smbldap-config
/usr/sbin/smbldap-config
# smbldap-config
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
       smbldap-tools script configuration
       -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Before starting, check
 . if your samba controller is up and running.
 . if the domain SID is defined (you can get it with the 'net getlocalsid')

 . you can leave the configuration using the Ctrl-c key combination
 . empty value can be set with the "." character
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Samba needs to be started first !

verification-done on xenial and trusty, thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package smbldap-tools - 0.9.9-1ubuntu1.16.04.2

---------------
smbldap-tools (0.9.9-1ubuntu1.16.04.2) xenial; urgency=medium

  * debian/patches/0023_add_pod_smbldap-config.patch: Fix typo in
    backport (LP: #997172).

 -- Nishanth Aravamudan <email address hidden> Wed, 07 Sep 2016 14:13:07 -0700

Changed in smbldap-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for smbldap-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package smbldap-tools - 0.9.9-1ubuntu1.14.04.2

---------------
smbldap-tools (0.9.9-1ubuntu1.14.04.2) trusty; urgency=medium

  * debian/patches/0023_add_pod_smbldap-config.patch: Fix typo in
    backport (LP: #997172).

 -- Nishanth Aravamudan <email address hidden> Wed, 07 Sep 2016 14:16:43 -0700

Changed in smbldap-tools (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.