Active Directory Integration doc points to a broken link

Bug #1836371 reported by Maxim Doucet on 2019-07-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Server Guide
Status tracked in Bionic
Bionic
Undecided
Doug Smythies
Trunk
Undecided
Unassigned

Bug Description

The Active Directory Integration documentation at https://help.ubuntu.com/lts/serverguide/samba-ad-integration.html points to a dead link.

The broken link is "Likewise Open documentation" on the second paragraph which URL is http://www.beyondtrust.com/Technical-Support/Downloads/files/pbiso/Manuals/ubuntu-active-directory.html

The wayback machine from archive.org at https://web.archive.org/web/20120801000000*/http://www.beyondtrust.com/Technical-Support/Downloads/files/pbiso/Manuals/ubuntu-active-directory.html shows that the latest version of the page is from 2012.

The documentation should maybe point to https://help.ubuntu.com/lts/serverguide/sssd-ad.html which is the correct way to use active directory for authentication.

Related branches

Doug Smythies (dsmythies) wrote :

So something like:

Another, use for Samba is to integrate into an existing Windows network. Once part of an Active Directory domain, Samba can provide file and print services to AD users. See the "SSSD and Active Directory" chapter of this guide for more details.

with that referral as a link?

Changed in serverguide:
status: New → Confirmed
Maxim Doucet (maximdoucet) wrote :

Yes, it would be great, thank you!

Changed in serverguide:
status: Confirmed → In Progress
assignee: nobody → Doug Smythies (dsmythies)
status: In Progress → Fix Committed
Changed in serverguide:
status: Fix Committed → Fix Released
Doug Smythies (dsmythies) wrote :

we need to target series here, because the 20.04 code (trunk) was migrated to discourse a few days before this revision.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers