openvpn setup references eni, needs updating for netplan

Bug #1772514 reported by Steve Langasek on 2018-05-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Server Guide
Undecided
Joshua Powers

Bug Description

The openvpn server advanced setup guide at <https://help.ubuntu.com/lts/serverguide/openvpn.html.en#openvpn-advanced-config> tells users how to set up the openvpn bridge only via /etc/network/interfaces. This should point instead to /etc/netplan.

Per <https://askubuntu.com/questions/1037223/ubuntu-17-10-openvpn-tap-help/1037955#1037955>, this should be straightforward, though complete equivalency does require an additional networkd-dispatcher hook; and making that work correctly is blocked on LP: #1772137.

Related branches

Joshua Powers (powersj) wrote :

I'll take a stab at updating https://help.ubuntu.com/lts/serverguide/openvpn.html.en under the "Advanced bridged VPN configuration on server" section.

... oh how I wish this was markdown

Changed in serverguide:
status: New → In Progress
assignee: nobody → Joshua Powers (powersj)
Doug Smythies (dsmythies) wrote :

O.K. thanks for taking this one on. Strictly speaking this bug report is a duplicate of 1772082, but O.K.

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2018-05-21 23:03, Joshua Powers wrote:
> ... oh how I wish this was markdown

There was a long list discussion about markup languages etc. starting with this message:

https://lists.ubuntu.com/archives/ubuntu-doc/2017-February/020255.html

Doug Smythies (dsmythies) wrote :

@Josh: I saw that you linked your local serverguide branch to this bug report, but didn't see a merge proposal. I assumed you are not ready for a MP yet, but am just checking. We'll publish the updated Serverguide after his one.

Joshua Powers (powersj) wrote :

Hi Doug!

Yeah, I was going to wait for the blocking bug (https://bugs.launchpad.net/bugs/1772137) to get resolved. Looks like there was some recent progress, so should be soon :)

Thanks for checking!

Joshua Powers (powersj) wrote :

The original bug is fix released I have asked for a review from Steve.

Joshua Powers (powersj) wrote :

Need a review from someone on the Ubuntu Documentation Committers team (~ubuntu-core-doc) and then we should be good to merge and update.

Changed in serverguide:
status: In Progress → Fix Committed
Changed in serverguide:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers