Server networking should be updated for systemd-networkd

Bug #1769007 reported by Brazen on 2018-05-04
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Server Guide
Undecided
Joshua Powers

Bug Description

The networking page for Bionic server still gives information for the deprecated ifupdown scripts. Bionic server is now using netplan.io and systemd-networkd for its network configuration.

http://manpages.ubuntu.com/manpages/bionic/man5/systemd.network.5.html

Related branches

Revision history for this message
Joshua Powers (powersj) wrote :
Changed in serverguide:
status: New → Confirmed
assignee: nobody → Joshua Powers (powersj)
Changed in serverguide:
status: Confirmed → In Progress
Changed in serverguide:
status: In Progress → Fix Committed
Revision history for this message
Joshua Powers (powersj) wrote :

@Doug - can we publish these fixes as the other bug I was working on (bug 1772514) is blocked by development work still.

Revision history for this message
Doug Smythies (dsmythies) wrote :

@Josh: O.K. what I'll do it not bother with a translation delay, for now. Once the other one is done we'll do a full translation update delay (say 2 weeks after the MP is merged).

Revision history for this message
Joshua Powers (powersj) wrote :

That works for me! Thank you!

Changed in serverguide:
status: Fix Committed → Fix Released
Revision history for this message
Brazen (jdinkel) wrote : Re: [Bug 1769007] Re: Server networking should be updated for systemd-networkd

There is an error in the bridging section. The config file needs to
include a definition for the adapter. Formatting may not look great in
email but the config file should look like this:

network:
  version: 2
  renderer: networkd
  ethernets:
    enp3s0:
      dhcp4: no
  bridges:
    br0:
      dhcp4: yes
      interfaces:
        - enp3s0

Also the usage of true/false and yes/no should probably stay consistent in
the documentation. The default config file has "dhcp4: yes" so my vote
would be stick with "yes" and "no" in the documentation. However the
documentation mostly uses "true" or "false" but has "dhcp4: yes" in the
bridging section. I think should either change that to "dhcp4: true" to
keep the documentation consistent, or switch all the documentation to using
"yes" and "no" to stay consistent with the default config file.

On Tue, Jun 5, 2018 at 9:09 AM, Doug Smythies <email address hidden>
wrote:

> ** Changed in: serverguide
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1769007
>
> Title:
> Server networking should be updated for systemd-networkd
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/serverguide/+bug/1769007/+subscriptions
>

Revision history for this message
Doug Smythies (dsmythies) wrote :

@Brazen: I confirm that bridging does not work as currently written. Furthermore, I confirm that it does work as you wrote.

While you have a good point with yes, no, true, false consistency, myself, I'll not deal with it at this time.

@Josh and/or David Britton: I'll do the edits and re-publication, if you're O.K. with the text the way it Brazen wrote it.

Changed in serverguide:
status: Fix Released → In Progress
Revision history for this message
Doug Smythies (dsmythies) wrote :

For dynamic and static IP address assignment, I do not understand why we say to create 99_config.yaml. Why not just edit the existing 01-netcfg.yaml file? Anyway, I edited, rather than create a new file.

Revision history for this message
Joshua Powers (powersj) wrote :

@Brazen: Thanks for bringing this up and proposing a fix.

re: yes/no or true/false, being more consistent would be nice, something that we should update on the netplan.io examples too, but can be fixed in a different bug.

@Doug: That file is not always present so I did not want to hardcode it. If you boot on a cloud instance you will instead have 50-cloud-init.yaml and if you originally had a system that was installed based on network manager: 01-network-manager-all.yaml

I'm good with the edit and re-publication.

Changed in serverguide:
status: In Progress → Fix Committed
Changed in serverguide:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers