Server - LAMP installation no longer asks for a mysql password

Bug #1752215 reported by Doug Smythies
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
bourne
Ubuntu Manual Tests
High
bourne
Ubuntu Server Guide
Undecided
Doug Smythies
mysql-5.7 (Ubuntu)
High
bourne

Bug Description

In the past, and even as recently as Feb 13th, the daily server ISO for bionic, has always asked for a mysql password during installation. Today it didn't and subsequently the mysql test step fails.

Related branches

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1752215

tags: added: iso-testing
tags: added: bionic
Revision history for this message
Brian Murray (brian-murray) wrote :

I tested this by installing mysql-server-5.7 on an Ubuntu virtual machine and also was not asked for a mysql password, so I suspect its a bug in the mysql-server package.

affects: debian-installer (Ubuntu) → mysql-5.7 (Ubuntu)
Joshua Powers (powersj)
Changed in mysql-5.7 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Robie Basak (racb) wrote :

This is intentional in mysql-5.7. The package defaults to Unix socket authentication instead. There is no longer a root password by default. As long as you're Unix root, you can log in as MySQL root.

I guess the test needs updating. Sorry, I didn't think of that when I landed this change in MySQL packaging.

Revision history for this message
Robie Basak (racb) wrote :

We should probably release note this too.

Revision history for this message
Joshua Powers (powersj) wrote :

Per the above I've added ubuntu-manual-tests as the test case will need to be updated.

Changed in ubuntu-manual-tests:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Doug Smythies (dsmythies) wrote :

So, if I understand correctly the test case step 27 should change from this:

Test MySQL:
    mysql -u root -p
    If you set the MySQL root account with a password, you will be prompted to enter it now. You should then be presented with a mysql prompt mysql> where you can enter some mysql commands:

to this:

Test MySQL:
    sudo mysql
    You should then be presented with a mysql prompt mysql> where you can enter some mysql commands:

Which I tried and it did work.

Revision history for this message
Robie Basak (racb) wrote :

Thanks Josh and Doug. This all seems right to me. Now that we have the ubuntu-manual-tests bug task, I'll mark the mysql-5.7 task Invalid as this is intentional behaviour in the package and only needs fixing in the test case.

Changed in mysql-5.7 (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Doug Smythies (dsmythies) wrote :

The 18.04 serverguide MYSQL chapter needs to updated also.

Changed in serverguide:
status: New → In Progress
assignee: nobody → Doug Smythies (dsmythies)
Revision history for this message
Kev Bowring (flocculant) wrote :

Can someone ack Doug's comment #6 and I'll get the testcase change through asap.

Changed in ubuntu-manual-tests:
assignee: nobody → Kev Bowring (flocculant)
status: Confirmed → In Progress
Revision history for this message
Robie Basak (racb) wrote :

> Can someone ack Doug's comment #6 and I'll get the testcase change through asap.

Consider Doug's comment #6 acked (I thought I'd done this in #7 but I guess I wasn't clear, sorry). Thanks!

Revision history for this message
Kev Bowring (flocculant) wrote :

@racb - thanks for that - all done for testcases

Changed in ubuntu-manual-tests:
status: In Progress → Fix Released
Changed in serverguide:
status: In Progress → Fix Committed
Changed in serverguide:
status: Fix Committed → Fix Released
Revision history for this message
DigiAngel (jlay) wrote :

As I'm just doing a fresh 18 install, it would be really nice if surprises like this could be documented somewhere. The below:

https://wiki.ubuntu.com/BionicBeaver/ReleaseNotes

https://help.ubuntu.com/lts/serverguide/mysql.html.en

contain no information about this bug; I end up having to search and poke around and finally find answers in the forums.

Revision history for this message
Doug Smythies (dsmythies) wrote :

Well, The serverguide was update for this, and the password stuff therein was deleted. There is no need to say anything else.

Revision history for this message
Ruj (akavipat) wrote :

I still see it there at https://help.ubuntu.com/lts/serverguide/mysql.html.en . Is this because of web server cache?

Revision history for this message
Doug Smythies (dsmythies) wrote :

@Ruj: I don't know. It is gone in the master code and in anything I look at from here.

Revision history for this message
brucefulton (brucefulton) wrote :

Isn't this a problem for applications using mysql that ask for the root password for mysql? I can give mysql a root password, but it fails for a user other than root using the syntax mysql -u root -p.

Revision history for this message
Robie Basak (racb) wrote :

> Isn't this a problem for applications using mysql that ask for the root password for mysql?

You can set a MySQL root password if needed. This isn't recommended for a typical single-machine deployment, but it is possible.

bourne (lahpo)
Changed in ubuntu-release-notes:
status: New → Confirmed
status: Confirmed → Incomplete
status: Incomplete → New
status: New → Fix Released
assignee: nobody → bourne (lahpo)
Changed in ubuntu-manual-tests:
assignee: Kev Bowring (flocculant) → bourne (lahpo)
Changed in serverguide:
assignee: Doug Smythies (dsmythies) → bourne (lahpo)
Changed in mysql-5.7 (Ubuntu):
assignee: nobody → bourne (lahpo)
status: Invalid → Fix Released
Changed in serverguide:
assignee: bourne (lahpo) → Doug Smythies (dsmythies)
Robie Basak (racb)
tags: added: triage
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers