build process extra doctype directive

Bug #1676058 reported by Doug Smythies
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Server Guide
Low
Doug Smythies
Trunk
Low
Doug Smythies
ubuntu-docs (Ubuntu)
Low
Gunnar Hjalmarsson

Bug Description

The serverguide build process now results in two doctype directives instead of 1. This did not occur a couple of years ago, and still does not occur in the basic build step with yelp-build. Therefore the issue is likely introduced during the post build Makefile manipulations in the language substitution step. i.e. the sed command is messed up.

I am not aware of any negative side effects.

Example: This:

<!DOCTYPE html>
<!DOCTYPE html>
<html lang=en>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

should be this:

<!DOCTYPE html>
<html lang=en>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

description: updated
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

The same is true for the desktop guide. Just pushed a change to trunk, but I don't bother to change the branches for released versions.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Low
status: New → Fix Committed
Revision history for this message
Doug Smythies (dsmythies) wrote :

@Gunnar : you are too fast for me. I would have checked out desktop docs eventually, particularity since that is where I stole that part of the Serverguide Makefile from in the first place.

Because builds with a 14.04 computer used to work fine and that part of the Makefile is so old, I can only assume that yelp-build didn't use to put in the doctype directive, but that now it does. However, I'm not going waste time figuring it out for certain.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2017-03-25 20:02, Doug Smythies wrote:
> @Gunnar : you are too fast for me.

:) I made a mental note about it when we played with Makefile the other day. Your bug report served as a reminder.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 17.04.3

---------------
ubuntu-docs (17.04.3) zesty; urgency=medium

  * html/ubuntu.xsl:
    - Specify search box width (LP: #1675452).
  * html/Makefile:
    - Drop duplicate doctype directive (LP: #1676058).
  * The latest translations exported from Launchpad.

  [ Doug Smythies ]
  * Several screenshots updated.

 -- Gunnar Hjalmarsson <email address hidden> Fri, 31 Mar 2017 01:00:00 +0200

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers