submit button of find field is shifted down

Bug #1675452 reported by Peter Mahnke
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Online publishing of the Ubuntu documentation
Medium
Gunnar Hjalmarsson
Ubuntu Server Guide
Medium
Doug Smythies
Trunk
Medium
Doug Smythies
ubuntu-docs (Ubuntu)
Medium
Gunnar Hjalmarsson
Trusty
Medium
Gunnar Hjalmarsson
Xenial
Medium
Gunnar Hjalmarsson
Yakkety
Medium
Gunnar Hjalmarsson
Revision history for this message
Doug Smythies (dsmythies) wrote :

Can we get some more details please. So far, I am unable to recreate the situation shown in the screen shot.

Revision history for this message
Doug Smythies (dsmythies) wrote :

O.K., I have re-created the issue on my test 17.04 desktop (VM) and my 16.10 test Laptop using the default firefox web browser.

The issue does not occur with any of 3 different web browsers from my windows 10 laptop.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Revision history for this message
Doug Smythies (dsmythies) wrote :

16.04 Ubuntu desktop with default firefox has the issue.

14.04 Ubuntu desktop with default firefox does NOT have the issue. (45.0+build2-0ubuntu0.14.04.1)(not up to date, and I see firefox in the update list. Will report back later after updates).

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Yep, it seems to be a Firefox issue. I attach an image showing what it looks like for me.

affects: ubuntu-docs (Ubuntu) → help.ubuntu.com
Changed in help.ubuntu.com:
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
Doug Smythies (dsmythies) wrote :

So now my 14.04 desktop VM has firefox 52.0.1+build2-0ubuntu0.14.04.1 and it has the issue.

@Gunnar : I get what you get, which I figured was close enough. Anyway, not a docs issue.

affects: help.ubuntu.com → firefox
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote : Re: [Bug 1675452] Re: submit button of find field is shifted down

I'm not so sure... IMO we should keep it as a h.u.c issue for now. I
suspect that tweaking the CSS file might help.

/ Gunnar

On 2017-03-23 19:16, Doug Smythies wrote:
> So now my 14.04 desktop VM has firefox 52.0.1+build2-0ubuntu0.14.04.1
> and it has the issue.
>
> @Gunnar : I get what you get, which I figured was close enough. Anyway,
> not a docs issue.
>
>
> ** Project changed: help.ubuntu.com => firefox
>

Revision history for this message
Pavel (mpa8) wrote :

Details:
Lubuntu 16.04
Firefox 52.0.1 (x64)

Changed in help.ubuntu.com:
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Doug Smythies (dsmythies) wrote :

The attached composite is screenshots segments from different browsers on different OS's.
The boxes under Ubuntu with and up to date firefox are way bigger than they should be and so they go beyond the overall containment box, which we define, and wrap around to the next line. Why? I think, but am not sure yet, that the two boxes inside our defined overall box are filled out by the call to google cse (Custom Search Engine). Why would those boxes be different in, so far, that one case?

I have tested 4 different browsers with windows 10, 2 different browsers with an apple, and an old old version of firefox with Ubuntu desktop, and all worked fine. Newer firefox with Ubuntu desktop doesn't work.

Revision history for this message
Doug Smythies (dsmythies) wrote :

This is a two screen shots composite from an old test google cse (Custom Search Engine) that Gunnar and I used one time. It seems to work o.k. with Ubuntu and firefox.

Revision history for this message
Pavel (mpa8) wrote :

What is decision?

Revision history for this message
Doug Smythies (dsmythies) wrote :

Pavel wrote:
> What is decision?

Answer: Give us a few days.

Revision history for this message
Doug Smythies (dsmythies) wrote :

We can make the box bigger, but I want to understand what is wrong. The attached is with this difference:

doug@s15:~/docs-trunk/z/html$ bzr diff
=== modified file 'html/ubuntu.xsl'
--- html/ubuntu.xsl 2016-12-13 14:09:30 +0000
+++ html/ubuntu.xsl 2017-03-24 06:26:47 +0000
@@ -134,14 +134,14 @@
 }

 #search-box {
- margin-left: 660px;
+ margin-left: 600px;
     -moz-border-radius: 0px 0px 4px 4px;
     -webkit-border-bottom-left-radius: 4px;
     -webkit-border-bottom-right-radius: 4px;
     -moz-box-shadow: #bbb 0px 0px 2px;
     -webkit-box-shadow: #bbb 0px 0px 2px;
     background-color: #F2F2F2;
- width: 290px;
+ width: 350px;
     height: 33px;
     padding: 7px 0 0 10px;
 }

Revision history for this message
Pavel (mpa8) wrote :

may be problem in difference between default size of elements in browsers. in FF input width: 200px
in Chrome width: 150px;

Revision history for this message
Pavel (mpa8) wrote :

the adding to css:
input[name="q"] {
    width: 150px;
}
I think may fix this one

Revision history for this message
Chris Perry (clissold345) wrote :

As far as I remember there wasn't a problem (when viewing the help with Firefox) a week or two ago. The problem may have only appeared with the latest update to Firefox (52.0.1), which appeared in my list of updates two or three days ago (Ubuntu 16.04). The problem occurs for all (HTML) versions of the desktop help (12.04, 14.04, 16.04, 16.10, 17.04).

Revision history for this message
Doug Smythies (dsmythies) wrote :

@Pavel: The problem is that we do not define the query box or the adjacent button box, we only define the overall containment box (or lack thereof, as is the subject of this bug report). They are done via a call to a Google CSE (Custom Search Engine). I'm trying to get access (for Gunnar and I) to the CSE.

Maybe something in the show_afs_search.js file might help, but it is an almost impossible to read and understand file. I did try a newer version of it last night though.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2017-03-24 10:20, Pavel wrote:
> the adding to css:
> input[name="q"] {
> width: 150px;
> }
> I think may fix this one

I think so too.

On 2017-03-24 15:36, Doug Smythies wrote:
> @Pavel: The problem is that we do not define the query box...

We don't currently, so let's do so. Please consider my latest commit to the desktop guide trunk:

http://bazaar.launchpad.net/~ubuntu-core-doc/ubuntu-docs/trunk/revision/619#html/ubuntu.xsl

no longer affects: help.ubuntu.com
Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → Fix Committed
Changed in serverguide:
importance: Undecided → Medium
status: New → Triaged
Changed in ubuntu-docs (Ubuntu Trusty):
importance: Undecided → Medium
status: New → Triaged
Changed in ubuntu-docs (Ubuntu Xenial):
importance: Undecided → Medium
status: New → Triaged
Changed in ubuntu-docs (Ubuntu Yakkety):
importance: Undecided → Medium
status: New → Triaged
affects: firefox → installation-guide
Revision history for this message
Doug Smythies (dsmythies) wrote :

O.K. Gunnar, Pavel, I now understand what I was not understanding before. It looks O.K. on my test web site. I'll assign myself the serverguide, no use fixing the 12.04 serverguide.

no longer affects: serverguide
affects: installation-guide → serverguide
Revision history for this message
Pavel (mpa8) wrote :

Thank you for your cooperation. I'm newbie here and I do not understand whole functions of the this site, so please let me know (In detail) if I need to do something.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Pavel: There is nothing else you need to do. You both reported the issue and provided a solution, and that's much appreciated. We're about to implement it. (The pages are the result of a build process, so there are a few things to consider.)

Thanks again!

Changed in ubuntu-docs (Ubuntu Trusty):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → Fix Committed
Changed in ubuntu-docs (Ubuntu Xenial):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → Fix Committed
Changed in ubuntu-docs (Ubuntu Yakkety):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → Fix Committed
Changed in help.ubuntu.com:
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → Fix Committed
Changed in help.ubuntu.com:
status: Fix Committed → Fix Released
Changed in ubuntu-docs (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in ubuntu-docs (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in ubuntu-docs (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 17.04.3

---------------
ubuntu-docs (17.04.3) zesty; urgency=medium

  * html/ubuntu.xsl:
    - Specify search box width (LP: #1675452).
  * html/Makefile:
    - Drop duplicate doctype directive (LP: #1676058).
  * The latest translations exported from Launchpad.

  [ Doug Smythies ]
  * Several screenshots updated.

 -- Gunnar Hjalmarsson <email address hidden> Fri, 31 Mar 2017 01:00:00 +0200

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers