Failed to load installer components

Bug #1294908 reported by Doug Smythies on 2014-03-20
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Server Guide
Status tracked in Trunk
Trunk
Undecided
Doug Smythies

Bug Description

My minimum requirements test computer will not install the Trusty 32 bit server daily ISO (I have tried 2013.11.25; 2103.12.02; 2014.03.18; 2014.03.19). It installs the 13.10 32 bit Server edition fine, and will update from there to 14.04.

A screen shot will be added.

Screen says:

Load Installer components from CD
Failed to Load installer components.
Loading apt-cdrom-setup failed for unknown reasons. Aborting.

The most likely root issue here is that my test computer only has 128 Megabytes of memory.

Using VM's:

For Saucy server 13.10 a minimum of 102 Megabytes memory is required

For Trusty server 14.04 a minimum of 165 Megabytes memory is required

Therefore installer memory requirements have increased by 64 megabytes.

(which is O.K., we just need to increase the minimum requirements specification for Ubuntu Server (which I have done, on both the wiki and the Ubuntu Serverguide))

On average the installer memory requirements increase by 32 megabytes per year. 16.04 Server needs 256 megabytes of memory. However, the gap between
the amount of memory needed to install and the amount of memory needed to actually run seems to be shrinking. This bug report was originally filed against the installer because it seemed insane that the installer needed so much more memory that the server needed to run. I think I'll delete the debian-installer as "Affects".

Hardware profile:
http://www.smythies.com/~doug/network/s06_profile/index.html

Related branches

Doug Smythies (dsmythies) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1294908

tags: added: iso-testing
Doug Smythies (dsmythies) wrote :

I verified using VM's: 13.10 server 128 Megabytes is enough memory; 14.04 needs about 165 megabytes of memory.

description: updated
description: updated
Dimitri John Ledkov (xnox) wrote :

@dsmythies is that with or without swap activated from hardware?

Also note that ubuntu server does not use ubiquity.

affects: ubiquity (Ubuntu) → debian-installer (Ubuntu)
Doug Smythies (dsmythies) wrote :

"@dsmythies is that with or without swap activated from hardware?" I do not know.

I got "ubiquity" from here: http://iso.qa.ubuntu.com/ , but thanks for changing it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
wu (piazini) wrote :

RAM little,you need 512M+.

Don Tai (dontai-canada) wrote :

Used the ubuntu 16.04 server x386 iso (http://zw.releases.ubuntu.com/16.04/ubuntu-16.04.2-server-i386.iso), burned to a DVD. My old desktop has 310mb ram, P3 800mhz. Received this same error. Could not continue with install.. Documentation says 192mb minimum. This is untrue.

Doug Smythies (dsmythies) wrote :

@Don Tai : I see you didn't subscribe to this thread.
256 megabytes of ram works for me, using the exact same iso as you did.
224 megabytes does not work.

description: updated
no longer affects: debian-installer (Ubuntu)
Don Tai (dontai-canada) wrote :

Hi Doug. I have 256M mem + 64M onboard = 320M. Maybe something stole 10M, but startup says 310mb.

Doug Smythies (dsmythies) wrote :

@Don: I do not know why it does not work for you, but worked for me. While I did mine installation as a virtual machine, I have never noticed a difference in requirements before.

Jerome Potts (jerome-potts) wrote :

Installing 16.04.3 32-bit server in VirtualBox in Windows 7 worked for me but with 384 MB. The stated minimum of 256 had the install abort on the loading of apt-cdrom-setup. I increased memory to 320, which went a bit further but aborted on loading the installation partition manager ('didn't jot down its exact name). I then increased to 384 and the installation went through.

Doug Smythies (dsmythies) wrote :

@Jerome: I confirm your findings. This seriously annoying because it is the Debian installer that needs more memory than actually just running the server.

I got: 340 Megabytes, or more, is fine; 336 Megabytes, or less, doesn't work; 338 Megabytes doesn't work, but doesn't fail gracefully, networking messes up.

Doug Smythies (dsmythies) wrote :

Just for my own information: The resulting server runs fine with 149.25 Mega bytes (152832 Kilo Bytes), but not with 147.125 Mega Bytes (150656 Kilo Bytes).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers